question

67044388 avatar image
0 Votes"
67044388 asked LucasLiu-MSFT edited

MSExchangeMailboxAssistants event 4999

MS Windows 2019, MS Exchange 2019 CU7

MS Windows and MS Exchange are installed with Russian. An attempt was made to switch the Windows interface to English, after which the MSExchangeMailboxAssistants service starts with an error and stops. I tried to return the Windows interface language back to Russian, but the service error remained.

Thanks for any help.

Error text:
Watson report about to be sent for process id: 26956, with parameters: E12IIS, c-RTL-AMD64, 15.02.0721.008, MSExchangeMailboxAssistants, M.Exchange.Assistants, M.E.A.AssistantsRpcServer.RegisterAssistant, System.ArgumentException, 503a-dumptidset, 15.02.0721.008.
ErrorReportingEnabled: False

office-exchange-server-itpro
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

67044388 avatar image
0 Votes"
67044388 answered LucasLiu-MSFT edited

Everything was decided by installing CU8. The service MSExchangeMailboxAssistants is working normally, there are no errors.

· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi @67044388 ,
I am glad to hear that this issue have been solved. Thanks for you sharing the solution.
You can mark the solution as an answer when you are free, which can help more people who have the same issue.



If the response is helpful, please click "Accept Answer" and upvote it.
Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.



0 Votes 0 ·
LucasLiu-MSFT avatar image
0 Votes"
LucasLiu-MSFT answered LucasLiu-MSFT commented

Hi @67044388 ,
Are there any Exchange functions that are not working properly?
Does any specific error pop up when you start the MS Exchange Mailbox Assistant service?
Do you try to restart the Exchange server and MSExchange Mailbox Assistants service? If not, please try.
1.1.Please run the following command to make sure that all required service are running:

 Test-ServiceHealth

2.According to the error information, we could only know that Microsoft Exchange Assistants service failed. It may not be possible to know the root cause of the error, so please check if there are any related errors in the event log, or if there are any errors in Exchange. Please share the information with us, but please pay attention to covering your personal information.



If the response is helpful, please click "Accept Answer" and upvote it.
Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.




· 5
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

In order
- Mail approval does not work. A letter comes for approval, you press "approve", but the letter is not delivered to the addressee.
- When starting the service MSExchangeMailboxAssistants, an error appears with the number 4999, source "MSExchange Common" and the text:

Watson report about to be sent for process id: 26956, with parameters: E12IIS, c-RTL-AMD64, 15.02.0721.008, MSExchangeMailboxAssistants, M.Exchange.Assistants, M.E.A.AssistantsRpcServer.RegisterAssistant, System.ArgumentException, 503a-dumptidset, 15.02.0721.008. ErrorReportingEnabled: False

  • Restarting the service. Restarting the server. The error remains.

  • Test-ServiceHealth



    Blockquote



Once again, I want to clarify that the service starts and stops immediately with error 4999 and so on forever

I beg your pardon for my english, google translate

0 Votes 0 ·
image.png (187.3 KiB)

Hi @67044388 ,
Please run the following command to check if the arbitration mailbox is complete.

 Get-mailbox -arbitration

77782-image.png

Please try to run the following command to moving the arbitration mailbox to another mailbox database. Then try to restart MSExchangeMailboxAssistants service again.

 Get-mailbox -arbitration | New-moverequest -targetdatabase <DBName>


As mentioned above, we could only know that Microsoft Exchange Assistants service failed from Event ID 4999. Please try to restart the MSExchangeMailboxAssistants again and see if there have any other related error logs in the Event Viewer.



If the response is helpful, please click "Accept Answer" and upvote it.



0 Votes 0 ·
image.png (38.0 KiB)

Hi @37044336 ,
Do suggestions above help? If the issue has been resolved, please click “Accept as answer” to mark helpful reply as an answer, this will make answer searching in the forum easier and be beneficial to other community members as well.

Thanks for your understanding.



If the response is helpful, please click "Accept Answer" and upvote it.
Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


0 Votes 0 ·

Sorry for the long silence.

  1. Get-mailbox -arbitration
    79217-image.png

  2. Get-mailbox -arbitration | New-moverequest -targetdatabase <DBName>
    I will do this on 03/26/2021.


Thank you for your help.




0 Votes 0 ·
image.png (129.3 KiB)

Hi @67044388
Ok, looking forward to your feedback.




If the response is helpful, please click "Accept Answer" and upvote it.
Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


0 Votes 0 ·