Datafactory dataflow run on Azure IR With Time to Live(TTL>0) Error

ri,shoshun 411 Reputation points

When I Run PipeLine including dataflow on Azure IR (TTL = 15'), the following error occurred.
.error message: Operation on target'dataflow_test' failed: Operation returned an invalid status code'InternalServerError'

.dataflow [dataflow_test] is simple:
Source (csv)-> DerivedColumn-> sink (csv)
*source, sink on azure IR (TTL = 0)

.pipeline's dataflow Setting:

  1. Run on (Azure IR): Azure IR With Time to Live (TTL) 15 minutes -> run error
  2. Run on (Azure IR): Azure IR With Time to Live (TTL) 0 minutes -> run success

If you know the solution, Please help me!

Azure Data Factory
Azure Data Factory
An Azure service for ingesting, preparing, and transforming data at scale.
7,181 questions
{count} votes

Accepted answer
  1. ri,shoshun 411 Reputation points

    As requested, today I created 3 new IRs((10,15,30Min)) and test, all success!.
    Thank you for your support.
    We will close this QA.

1 additional answer

Sort by: Most helpful
  1. KranthiPakala-MSFT 39,007 Reputation points Microsoft Employee

    @ri,shoshun , Engineering team is looking into the issue based on the run ID's provided. In the meantime, to mitigate the issue, could you please try creating a new Azure IR with TTL enabled and check if you notice the same behavior or not? If you notice the same error even after creating a new Azure IR with TTL, please let us know so that we can update back to product team .

    Thank you

    0 comments No comments