Retrieve an online meeting by JoinWebUrl stopped working in Beta API

angela83 101 Reputation points

Hi Team

Retrieve an online meeting by JoinWebUrl as documented here onlinemeeting-get was working fine on Monday 8th of March and it stopped working yesterday and today is still not working. I am getting the following error on the GET request

"The query specified in the URI is not valid. Could not find a property named 'JoinWebUrl' on type 'Default.<>f__AnonymousType0_1Of<>f__AnonymousType1_2OfString_String'."

Is there any reason for this or is someone else facing the same issue?

Microsoft Graph Cloud Communications API
Microsoft Graph Cloud Communications API
A Microsoft API that adds a new dimension to how your apps and services interact with users through various communications-related features, such as calling and online meetings.
131 questions
0 comments No comments
{count} votes

Accepted answer
  1. angela83 101 Reputation points

    Hi @Danstan agreed /beta apis are subject to change.
    I have just tried it again and it is still failing for me. I am first getting the joinWebUrl from a callRecord and pasting it as is to get the onlineMeeting as below
    Am I doing anything wrong here? does it work for JoinWebUrl that are a few days old?



1 additional answer

Sort by: Most helpful
  1. Danstan Onyango 3,246 Reputation points

    First, APIs under the /beta version in Microsoft Graph are subject to change and are not supported for use in Production so keep this in mind.

    That said, the endpoint works fine for me. I think you are using a link that is not a valid JoinWebUrl or it points to a meeting that does not exist. Here is a sample  

    See the screenshot below

    0 comments No comments