Create blob action replaces file name that contains plus symobl with a space. Is it supported?

Mohammad Amer 81 Reputation points


I am using Create Blob action to create files in azure blob storage. I have some files that have a (+) symbol in the names of the files.
The action create the files but unfortunately, it replaces (+) symbol with a space. Is the (+) symbol supported or not?

I see it the (Inputs) of the action, the file name has the (+) symbol but in the action (Output) (+) symbol replaced with a space

I am able to rename any file or folder with a (+) symbol in the name in Azure Storage explorer.
Is there any work around to keep this (+) symbol in the file names?

Appreciate your help!

Azure Storage Accounts
Azure Storage Accounts
Globally unique resources that provide access to data management services and serve as the parent namespace for the services.
1,831 questions
Azure Blob Storage
Azure Blob Storage
An Azure service that stores unstructured data in the cloud as blobs.
1,688 questions
Azure Logic Apps
Azure Logic Apps
An Azure service that automates the access and use of data across clouds without writing code.
2,112 questions
{count} votes

Accepted answer
  1. ChaitanyaNaykodi-MSFT 13,131 Reputation points Microsoft Employee

    Hello @Mohammad Amer , the blob name is url-encoded in the backend, that is the reason why the '+' is replaced by ' '. Can you please try replacing the + with %2b? I gave it a quick try and it worked for me. In addition to this I will see if we can add a note to the documentation regarding the same. Thank you for bringing this to our attention.

    Please let me know if there are any additional concerns. Thank you!

1 additional answer

Sort by: Most helpful
  1. Jithin Joseph 1 Reputation point

    Hi ,
    I have a logic app that moves files from one location to another, unfortunately any files with filename with + sign it failed
    Is this a limitation of Logic App
    I tried replacing + with %2b and it worked but the file name will have %2b instead of + is there a solution to this

    0 comments No comments