Unable to connect to Azure Database due to network settings issue

Maruthi Karthik 1 Reputation point

Unable to connect to Azure SQL via portal, stating the issue as below error:

A connection to the server 'XXXX.database.windows.net' could not be established. This might indicate an issue with your local firewall configuration or your network proxy settings.

I tried the below:

Opened ports 1433, 443
Added Client IP in the firewall settings and the IP is whitelisted for access

Still the issue exists

Azure Active Directory
Azure Active Directory
An Azure enterprise identity service that provides single sign-on and multi-factor authentication.
14,666 questions
0 comments No comments
{count} votes

2 answers

Sort by: Most helpful
  1. Manu Philip 14,546 Reputation points MVP

    Hello @MaruthiKarthik,

    Check "SQL Server Configuration Manager" for "SQL Server Network Configuration". Under "Protocols for Name", make sure that "TCP/IP" is enabled. Select "IP Addresses" Tab -and- Go to the last entry "IP All". Enter "TCP Port" 1433.
    Now Restart "SQL Server .Name." from windows services. Check if it resolves the issue

    Please mark as "Accept the answer" if the above steps helps you. Others with similar issues can also follow the solution as per your suggestion



    0 comments No comments

  2. Armand Brunelle 491 Reputation points

    Hi @Maruthi Karthik

    Have you got a connector as a redirect that have policy to Inbound traffic, and outbound traffic, if your port are forwarded, open, whitelisted, i would do a
    connectivity test, see what kind of statistics results output from there and pursue investigations.

    Would you mind giving a configuration of your current system, but also what you are trying to do. Right now the interpretation of this work order is
    incomplete. Actual Configuration and Action that lead to your problem, will clarify and you get more chance to resolve your demands.

    Sometimes providing config, spec and details will be useless, but here we could take them. Please, on your futur post, make sure to add those details.

    I hope it help you.

    Regards, Armand B.

    "If the answer did help you, Upvote it, other user will access those informations swiftly."

    0 comments No comments