copying function from local system to azure FA

Islam, Amreen Nahid 21 Reputation points
2021-03-15T08:45:18.037+00:00

Max retries exceeded with url: /api/zipdeploy?isAsync=true (Caused by SSLError(SSLError("bad handshake: Error([('SSL routines', 'tls_process_server_certificate', 'certificate verify failed')],)",),))

Not using any proxy

Azure Functions
Azure Functions
An Azure service that provides an event-driven serverless compute platform.
4,642 questions
{count} votes

2 answers

Sort by: Most helpful
  1. MayankBargali-MSFT 69,991 Reputation points
    2021-03-15T13:41:32.253+00:00

    @Islam, Amreen Nahid Thanks for sharing the details. The error message is observed when you there is a proxy behind corporate network or introduced by tracing tools like Fiddler, mitmproxy, etc
    Just want to confirm if you have tried to implement the suggested action here. Have you tried to deploy the function from another network (non corporate) network to confirm that this is the issue is with the network in place?

    If you are on windows machine have you run the below command (run in cmd) to see if there is any proxy:
    netsh.exe winhttp show proxy

    0 comments No comments

  2. sadomovalex 3,631 Reputation points
    2021-03-15T14:20:41.34+00:00

    it can be also caused by antivirus which captures the traffic. If you have one try to temporary pause it, run the script and then resume back.

    0 comments No comments