Why is the joining an Azure AD option missing?

Andy Theuninck 16 Reputation points

I'm attempting to join a device to Azure Active Directory as documented here. When I get to the step that's supposed to list Alternate Actions for joining Azure or local, the Azure option isn't there. Only the local domain option appears.

The device is running Windows 10 Pro, build 1903 which appears to meet the minimum requirement (I've seen 1511 and 1703 listed in different Microsoft Learn). The device is not currently joined to a domain.

What's the best way to troubleshoot this? Are there known reasons the option might not appear as documented, or a way to do this from Powershell that might at least provide an error message as a hint what's happening?

Microsoft Entra ID
Microsoft Entra ID
A Microsoft Entra identity service that provides identity management and access control capabilities. Replaces Azure Active Directory.
20,543 questions
{count} votes

10 answers

Sort by: Most helpful
  1. Pavel yannara Mirochnitchenko 12,411 Reputation points MVP

    @TobiWanKenobi you need to be local admin to do this. User cannot join device to AzureAD.

    3 people found this answer helpful.

  2. AmanpreetSingh-MSFT 56,506 Reputation points

    Hi @Andy Theuninck ,

    Is your Windows 10 device already joined to on-premises Active Directory? If yes, you will not get the Azure AD join option because you would need to perform Hybrid Azure AD join in that case using either of below methods:

    You can try using below commands to join Azure AD and check the status:

    • DsRegCmd /join
    • DsRegCmd /status

    For debugging errors, you can check below event logs:

    Event Viewer > Application and Services logs > Microsoft > Windows > User Device Registration > Admin


    Please do not forget to "Accept the answer" wherever the information provided helps you. This will help others in the community as well.

    1 person found this answer helpful.

  3. Leon Laude 85,721 Reputation points


    The option won't be shown if your device is not connected to the Internet, make sure it is and make sure no firewall/web filter/proxy is blocking this option.

    Similar post here:

    Best regards,

  4. acgomes 16 Reputation points

    I'm having a somewhat similar issue, as "Join this device do AAD" does not show in Settings -> Access Work or School -> Connect.

    This is a Windows 10 Home 1909.

    By the way: did you configure AAD to allow users to join devices?

  5. Tom Urwin 1 Reputation point

    Hi there,

    Did this get solved? We have the same issue.

    Here are the specs:


    Yet the user does not have the option to connect to Azure AD, even when elevated to admin. We do not have an AD domain.


    0 comments No comments