Office 365 migration endpoint fails

asked 2021-03-15T19:12:29.137+00:00
David McBride 301 Reputation points

Can not create a migration endpoint in Office 365 to on-prem Exchange 2016. Everything else works, Outlook and OWA work. When I troubleshoot with Test-MigrationServerAvailability I keep getting "The RPC server is unavailable". I have tried autodiscover switch and manually setting the rpc server and exchange server. Same error. I have verified the user account permissions and valid login with OWA.
Any ideas would be greatly appreciated.

Microsoft Exchange Online Management
Microsoft Exchange Online Management
Microsoft Exchange Online: A Microsoft email and calendaring hosted service.Management: The act or process of organizing, handling, directing or controlling something.
2,877 questions
{count} votes

5 answers

Sort by: Most helpful
  1. answered 2021-03-16T02:20:52.76+00:00
    Joyce Shen - MSFT 16,296 Reputation points Microsoft Employee

    Hi @David McBride

    According to your description above, you failed creating a migration end point in O365 side. What migration are you going to perform?

    Could you please provide the complete error information you received when perform the migration and create the migration endpoint?

    Have you tried using ExRCA tool to test if there is any connectivity issue?

    Here is the official document introduces about the issue "The RPC server is unavailable" which occurs when you try to perform a cutover migration from an on-premises Exchange organization that uses Outlook Anywhere (also known as RPC over HTTP) to Exchange Online.

    We may also try creating the migration endpoint manually, New-MigrationEndpoint. Espically check the descriptions for different types of migrations


    If an Answer is helpful, please click "Accept Answer" and upvote it.

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.
     

    No comments

  2. answered 2021-03-16T13:26:55.747+00:00
    David McBride 301 Reputation points

    I am finding inconsistent results. When I run command Test-OutlookWebServices -Identity user@keyman .com -MailboxCredential (Get-Credential) over and over I get different results. Occasionally it says successful for all 4 tests.
    The Autodiscover: Outlook Provider seems to always be successful.
    The Exchange Web Service sometimes is Failure.
    The Availability Service sometimes is Failure
    The Offline Address Book is always seems to be successful.
    Where do I look for these issues?
    Thanks


  3. answered 2021-03-26T18:05:36.11+00:00
    David McBride 301 Reputation points

    When I access the Autodiscover URL:
    <Autodiscover xmlns="http://schemas.microsoft.com/exchange/autodiscover/responseschema/2006">
    <Response>
    <Error Time="12:55:45.6740272" Id="3668329655">
    <ErrorCode>600</ErrorCode>
    <Message>Invalid Request</Message>
    <DebugData/>
    </Error>
    </Response>
    </Autodiscover>
    When I run Get-WebServicesVirtualDirectory
    Name Server InternalUrl


    EWS (Default Web Site) server02 https://server02.internal.local/EWS/Exchange.asmx
    EWS (Default Web Site) server01 https://server01.internal.local/EWS/Exchange.asmx
    EWS (Default Web Site) server03 https://server03.internal.local/EWS/Exchange.asmx

    Was there specific info from the command you were looking for?
    Thanks!!

    No comments

  4. answered 2021-03-28T19:54:45.283+00:00
    Michael Hahn 21 Reputation points

    Hello,

    How should the o365 migration point connect to your exchange? When the EWS (Default Web Site) is on an internal link?

    Have you tried to set the "exchange proxy" in O365 migration config to something like https://mail.xxx.net/EWS/Exchange.asmx ?

    you should check all the exchange url.

    Get-ClientAccessService
    Get-OutlookAnywhere
    Get-MapiVirtualDirectory
    Get-OabVirtualDirectory
    Get-ActiveSyncVirtualDirectory
    Get-WebServicesVirtualDirectory
    Get-EcpVirtualDirectory
    Get-OwaVirtualDirectory
    
    Look  what  you get back for
    -internalurl
    -externalurl
    
    at least the external url should be an "routable" domain. like https://mail.*****.net/.....
    

    And check your mx DNS entries with

    nslookup
    set type=mx
    mail.****.net
    or yourdomain.net (without mail.)

    No comments

  5. answered 2021-03-29T13:21:02.663+00:00
    David McBride 301 Reputation points

    Get-ClientAccessService - dont see anything for External - should there be?
    Get-OutlookAnywhere - ExternalUrl is correct
    Get-MapiVirtualDirectory - ExternalUrl is correct
    Get-OabVirtualDirectory - ExtrnalUrl is correct
    Get-ActiveSyncVirtualDirectory - ExternalUrl is correct (ExternalAuthenicationMethods is blank, what should it be?)
    Get-WebServicesVirtualDirectory - ExternalUrl is correct
    Get-EcpVirtualDirectory - ExternalUrl is correct
    Get-OwaVirtualDirectory - ExternalUrl is correct
    MX is correct
    Did I miss anything?
    Thanks!!