Opening Outlook gives "The Set of Folders Cannot be Opened”

kurt stichelmans 76 Reputation points
2021-03-17T11:23:03.407+00:00

Situation: Exchange 2016 cu18 with all the available patches.
Outlook: 2016 16.0.4966.1000 32-bit version.

No PST files. No cached mode. On-premise Exchange. Exchange is online all the time.
There is already a lot of information about this kind of issue but none does the trick for us.

What we see: One outlook profile. User has his own mailbox. And also in his profile he has another mailbox we use the credentials of that mailbox.
Sometimes when he opens his Outlook he gets the popup that Outlook cannot be opened and that the set of folders cannot be opened.

We tried changing add-ins, safe mode, new profiles, ... but the the important thing is that if we do nothing it solves itself after minutes, hours, .... although at that moment there are no issues with the connection of the Exchange server because the other 500 people can still work.

What we likely are seeing is that while opening Outlook the credentials are asked from the mailbox which is connected to the account of the user. So to be clear: I logon to windows with accountAA, I open Outlook and the primary mailbox is of course the mailbox of accountAA, but credentiasl are asked via a popup. In that popup I see the credentials of that added secondary mailbox. Of course I can change that to accountAA, fill out the password an Outlook opens.

Sometimes there is no popup at all and Outlook does not open.

When creating a new profile sometimes it opens without a problem, sometimes it doesn't. And when I go back to the original outlook profile it goes open without a notification.

Extra: there are only a few people who has seen this popup but I cannot say if it is always the same group of people. Some people reacts more often then others, that is true.

So I want to focus on the extra mailbox. Could this be an issue? We have a lot of people who have extra mailboxes. Yes some more than 10 in one Outlook profile. But as said earlier not everybody with extra mailboxes does have issues.

We also removed some Windows profiles and created them from scratch. but does not solved it completely.

What I want to ask is: could it be an issue on the Exchange server. related ot the virtual directories? Maybe our mapi settings are not as wished?
Now the authentication is as follows: windows authentication-ntlm and windows auth-negotiate are on. At IIS level default web site / mapi / only windows auth is on. At back end mapi has anonymous auth and forms auth on. Is that correct? Can't remember I have changed that in the past.

Hopefully we get a tip, even how small, and we can find the solution for this strange behaviour.

Best regards
Kurt

Outlook Management
Outlook Management
Outlook: A family of Microsoft email and calendar products.Management: The act or process of organizing, handling, directing or controlling something.
5,071 questions
Exchange Server Management
Exchange Server Management
Exchange Server: A family of Microsoft client/server messaging and collaboration software.Management: The act or process of organizing, handling, directing or controlling something.
7,499 questions
0 comments No comments
{count} votes

2 answers

Sort by: Most helpful
  1. Kael Yao-MSFT 37,676 Reputation points Microsoft Vendor
    2021-03-18T07:38:56.03+00:00

    Hi, Kurt.

    Thanks for your detailed information.

    However, sorry I still need to ask the following questions:

    1. Is the detailed error the same as in the following screenshot when you try to open the additional mailbox in Outlook?
      (Cannot expand the folder. the set of folders cannot be opened. network problems are preventing connection to Microsoft Exchange.)
      79044-91.png
      If you don't see the popup, does the additional mailbox show a status of disconnected and the folders are not updated?
      78980-92.png
    2. Do all the affected users use the same Outlook version? (Outlook 2016 16.0.4966.1000 32-bit version)
    3. Are the affected devices domain-joined?

    Here are some suggestions:

    1. To narrow down the problem, if possible, would you please try with Outlook 2013 and see if the problem persists?
    2. Please check if you can find some event ID 9646 generated in the application log on the Exchange server when the problem occurs.

    To my opinion, the problem may be caused by the MAPI session limit per user of the Exchange server.
    Is the additional mailbox shared with many users (more than 32)?

    If so, please follow this document: Managed Store Limits in Exchange Server

    1. Open regedit.exe and add the "Maximum Allowed Sessions Per User" to \HKEY_LOCAL_MACHINE \SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem.
    2. Set it value to 64 or larger and restart the "Microsoft Exchange Information Store" service.
    3. See if it works for you.

    If the response is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


  2. Kevin Vlasselaer 1 Reputation point
    2021-07-07T17:58:57.783+00:00

    Hi,

    I have the exact same issue.

    • Exchange & mailbox on-premise (but hybrid link with O365)
    • Sometimes users are opening outlook and get a "Cannot start Microsoft Outlook window. The set of folders cannot be opened. The attempt to log on to Microsoft Exchange has failed"
    • After somes minutes or Hours... The problem is gone and user can open outlook again without any problem
    • I also have the strange password pop-up after the initial setup of outlook -> For example when I delete the old profile and create a new one, I enter the e-mail address and password, it pass the configuration but when outlook open again, I get a pop-up for those users. I didn't have the problem with my own e-mail address.
    • When the user encounter the problem, the problem is present on all the devices (Citrix VDI, Physicall computers...) and with different Microsoft office version (2019 & Office 365).
    • We have multiple domaine and it seams that the users that are impacted are only on one of the other domain
    • Users that encounter those problems have always shared mailbox and most of time a lot of mailboxes (in place archive, shared mailbox...)
    • I found some error in the exchange servers saying that for the shared mailbox of the user impacted, "with AirSync exceeded the maximum of 250 objects of type message".

    I'm not sure that the last "tip" is directly related althroug it seams to be the more relevant.. (no link with the fact that it's only the users on a particular domain that are impacted).

    Best regards,

    0 comments No comments