BizTalk: Overriding the 10 min. max transaction timeout in a port using WCF-Custom(nettcp binding)

Biranchi narayan mohapatra 1 Reputation point
2021-03-17T14:33:30.217+00:00

Hi, I have a Send port in a BizTalk application that uses WCF-Custom(nettcp binding) with send timeout set to 10mins. As I understand from the WCF documentation that's the maximum timeout you can set. I have a scenario where, I have to increase the timeout beyond 10mins. To increase the timeout beyond 10mins, I have to update(I read in some documentation) machine config files both for .NET v2.0 and v4.0 for both x86 and 64bit. I made the below changes: 1. Under sectionGroup name="system.transactions" : allowExeDefinition="MachineOnly" to allowExeDefinition="MachineToApplication" 2. Further added the below section by setting the maximum timeout to 1hr. <system.transactions> <machineSettings maxTimeout="01:00:00" /> </system.transactions> Although, I have restarted the server but what I can see is the send port goes dehydrated after 10mins, although the SendTimeout is set to 20mins. I need your suggestions to help me in: 1. Knowing if the above steps carried are correct? 2. Is there any other way to increase the timeout beyond 10mins? 3. Any other suggestions? Any information around this will be really helpful and appreciated. Regards Biranchi

Microsoft BizTalk Server
Microsoft BizTalk Server
A family of Microsoft server products that support large-scale implementation management of enterprise application integration processes.
359 questions
0 comments No comments
{count} votes