Will the VS Installer Project ever be upgraded to have .NET 5 as a Launch Condition/Dependency?

Shawn Eckley 101 Reputation points
2021-03-18T12:25:38.457+00:00

Hi;
I am working on converting a small application .NET 5. This is only the first, the will be larger but along the same line.
The application i am working on is a combination of C#, Managed C++ and Native C++ projects. One of these projects is a dll project that during the release build gets encrypted as part of a post build event. This application has been migrated .NET 5. We currently create the installer by using the VS Installer Project. The problem with this is that .NET 5 now has to be a Launch Condition/Dependency. The launch conditions only goes up to .NET Framework 4.8.
Will the VS Installer project ever be upgrade to include more advanced .NET releases?

I have been testing out some of the newer installation project types like MSIX but they rely on being able to read the dependencies of the projects to decide which files to include. This turns out to be a problem with the encrypted dll because it is not seen as a dependency. In the VS installer projects we could explicitly state that that file needs to be included.

Any help or advice would be appreciated.

.NET
.NET
Microsoft Technologies based on the .NET software framework.
3,626 questions
0 comments No comments
{count} vote