VHDX Size limit on Replica Server?

Jens Mickerts 1 Reputation point
2021-03-18T13:54:03.203+00:00

Hi all, I have a strange issue on a Hyper-V Replica Server. I just start with some details. We are running the following Setup: Hyper-V 2016 Cluster (3 Nodes, Production, no further details required) Hyper-V 2016 Cluster (2 Nodes, Replica target) HP Proliant DL380 G9 Servers, patched to SPP 2020.9 (latest Service Pack for Proliant) OS Windows Server 2016 Datacenter, Patched to CU 02/2021 As Cluster Storage we are using Windows Storage Spaces with some 30TB of Storage. The whole setup works fine, Replication ist quite solid, but now I have one VM where I happen to have a large VHD(X), just shy of 4TB. The Problem is that on the Replica-Server I seem to have a size limit on the Cluster Shared Volume as I am unable to resize the VHD to more than 3999999999999 Bytes. There seems to be a limit to 4000000000000. If I try resize-vhd with this value (maybe starting with 4000000000001 Bytes, I have not tried that, though). Has anybody a clue why this happens? Kind regards, Jens

Hyper-V
Hyper-V
A Windows technology providing a hypervisor-based virtualization solution enabling customers to consolidate workloads onto a single server.
1,825 questions
Windows Server Clustering
Windows Server Clustering
Windows Server: A family of Microsoft server operating systems that support enterprise-level management, data storage, applications, and communications.Clustering: The grouping of multiple servers in a way that allows them to appear to be a single unit to client computers on a network. Clustering is a means of increasing network capacity, providing live backup in case one of the servers fails, and improving data security.
727 questions
No comments
{count} votes

3 answers

Sort by: Most helpful
  1. JiayaoZhu 3,891 Reputation points
    2021-03-19T09:03:08.717+00:00

    Hi,

    Thank you for your reply!

    According to your description, you seem to be unable to expand a VHDX with an initial disk size of 4TB in the cluster after the cluster replication is completed.

    I will first suggest you to confirm whether you are using static disk or dynamic disk. If you use static storage space allocation, the size of the disk space is determined at the beginning. You can only expand the disk with this type of disk when your storage space has enough unallocated disk space. If your storage space does not have enough unallocated disk space and you use static disk, then disk expansion cannot be properly performed.

    To check which disk type you used, you can open Hyper-V Manager>> inspect disk, and find the target disk file and right click to view the properties of the disk.

    If you have used dynamic disks, but the issue still exists, then your issue may be attributed to the shortage for your whole disk space. In this case, you can check your usage status of your cluster storage space.

    Thank you for your time!

    Best regards
    Joann

    --------------------------------------------------------------------------------------------------------------------

    If the Answer is helpful, please click "Accept Answer" and upvote it.

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    No comments

  2. Jens Mickerts 1 Reputation point
    2021-03-19T09:38:09.32+00:00

    Hi,

    the initial size is below 4TB as mentioned this seems to be related to an issue with a limit of 4000000000000 Bytes, which is well below 4TB. I was able to expand the disk to one byte less than this, but no further. There is some 5TB free space on the volume, and in the VHDX there were some GBs left, but expanding to the mentioned limit worked without issues. It is a basic disk and static as well. But as mentioned I was able to expand, but not above the mentioned size.

    Kind regards,

    Jens


  3. Jens Mickerts 1 Reputation point
    2021-03-23T22:12:17.44+00:00

    Hi Joann,

    sorry, but this log does not show an entry newer than last year and I tried the day I posted this issue.

    I hope you still have some ideas left. I have to thank you for YOUR time, I am just trying to get rid of an issue, you are the one helping.

    Kind regards,
    Jens