Unable to create cluster - timeout period expired

S J L 96 Reputation points
2021-03-18T15:58:58.957+00:00

Hi all,

I'm trying to create a cluster but the process keeps failing with the following message:

An error occurred while creating the cluster.
An error occurred creating cluster 'cluster'.
This operation returned because the timeout period expired

Cluster validation passed with two warnings (single NiC and system udpates aren't equal). Have checked event logs, and no warnings anywhere that I can see. Checked DNS event logs, and event logs on both nodes.

When trying to use Get-ClusterLog, it fails since the cluster service isn't running.

During the cluster creation process, the CNO does get created in AD and gets cleaned up afterwards when the cluster creation fails and rolls back.

At the moment, I have no idea what else I can check. Thank you in advance for any suggestions!

Windows Server 2016
Windows Server 2016
A Microsoft server operating system that supports enterprise-level management updated to data storage.
2,426 questions
Windows Server Clustering
Windows Server Clustering
Windows Server: A family of Microsoft server operating systems that support enterprise-level management, data storage, applications, and communications.Clustering: The grouping of multiple servers in a way that allows them to appear to be a single unit to client computers on a network. Clustering is a means of increasing network capacity, providing live backup in case one of the servers fails, and improving data security.
975 questions
0 comments No comments
{count} votes

Accepted answer
  1. S J L 96 Reputation points
    2021-03-22T05:16:48.76+00:00

    Okay, figured this out.

    The OS is Server 2016 Datacentre. Have rebuilt the servers several times, which includes the reinstall of WSFC feature and joining to domain. Looking at the logs folder, there's the cluster creation log which doesn't tell us anything helpful (just what I pasted in my OP). In the FcSrv.log, there's the following:

    ***** FcSrv Start ****
     00001c8c.00001dbc::2021/03/22-04:54:32.266  RetrieveHostLabel completed with status = 0
    00001c8c.00001dbc::2021/03/22-04:54:35.124  GenerateClusterCert completed with status = 0
    00001c8c.00001dbc::2021/03/22-04:54:35.218  StoreClusterSecret completed with status = 0
    00001c8c.00001dbc::2021/03/22-04:54:35.233  StoreClusterCert completed with status = 0
    ***** FcSrv Stop ****
    
    ***** FcSrv Start ****
     000023b8.000023c4::2021/03/22-04:57:36.231  ENTER CleanUpEvictedNode
    000023b8.000023d0::2021/03/22-04:57:36.231  ENTER EvictedNodeCleanupThreadProc
    000023b8.000023d0::2021/03/22-04:57:36.231  ENTER CleanUpNode
    

    Looks like the cluster service starts, waits for 3 minutes then stops again. Going through eventviewer showed a VERBOSE entry saying cluster service wasn't able to reach other node on 3343. Why that entry isn't shown as an error, and why that wasn't tested in the validation process, I have no idea. So opening up TCP 3343 in the security group fixed it (UDP 3343 was already open).

    0 comments No comments

1 additional answer

Sort by: Most helpful
  1. Xiaowei He 9,876 Reputation points
    2021-03-19T02:48:29.913+00:00

    Hi,

    1. What is the OS of the cluster nodes?
    2. Please try to re-install failover cluster role on the nodes, re-join the nodes into the domain, then turn off firewall on the nodes temporily, try to create the cluster again, check if it could work.
    3. If the cluster creation still not work, please turn to C:\Windows\Cluster\Reports, check if there's any reports and check the detailed information about the reports.
    4. Pleaes also open event viewer, and turn to Event viewer >Applications and Services Logs>Microsoft>Windows>FailoverClustering, check if there's any error logs.

    Thanks for your time!
    Best Regards,
    Anne

    -----------------------------

    If the Answer is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    0 comments No comments