question

StephenClark-3646 avatar image
0 Votes"
StephenClark-3646 asked KyleXu-MSFT answered

Error Updating On-Prem Hybrid Exchange 2016: no mailbox role detected

Hoping for some help with this.

When we’re trying to upgrade our hybrid on-prem exchange server; the pre-req’s fail saying no mailbox role on the on-premise server. It also has loads of other errors saying the user isn’t a member of the exchange organization management group…but the user is definitely in that group. As well as schema admins too.

I’m running as administrator too.

Very confused.

Anyone else had this issue?

office-exchange-server-administrationoffice-exchange-hybrid-itprooffice-exchange-server-deployment
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

KyleXu-MSFT avatar image
0 Votes"
KyleXu-MSFT answered KyleXu-MSFT commented

@StephenClark-3646

Take steps below to narrow down this issue:

  1. Double check on the account that you used to update Exchange contained in those group below:
    79433-qa-kyle-10-35-03.png

  2. Make sure that you login Exchange computer with domain account "YourDomain/adminAccount"

  3. Try to run Prepare command before installing Exchange server:

    E:\Setup.exe /IAcceptExchangeServerLicenseTerms /PrepareSchema
    E:\Setup.exe /IAcceptExchangeServerLicenseTerms /PrepareAD
    E:\Setup.exe /IAcceptExchangeServerLicenseTerms /PrepareDomain

After that, try to update Exchange server again, if you still cannot update Exchange server, could you provide detail information about this error?


If the response is helpful, please click "Accept Answer" and upvote it.
Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


· 3
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

@StephenClark-3646
I am writing here to confirm with you any update about this thread now?
If the above suggestion helps, please be free to mark it as an answer for helping more people.

0 Votes 0 ·

Hi there, just catching up on this thread. I’ve not had a chance to try again just yet. I plan on re-attempting the process this weekend.

I’ll come back once I’ve tried again!

Thanks for the post.

0 Votes 0 ·

Waiting for your good news.

1 Vote 1 ·
StephenClark-3646 avatar image
0 Votes"
StephenClark-3646 answered

Came across this in the logs.

[03/26/2021 18:49:13.0448] [0] [ERROR] Setup encountered a problem while validating the state of Active Directory: Exchange organization-level objects have not been created, and setup cannot create them because the local computer is not in the same domain and site as the schema master. Run setup with the /prepareAD parameter on a computer in the domain and site ***, and wait for replication to complete.

Trying this now...

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

StephenClark-3646 avatar image
0 Votes"
StephenClark-3646 answered

Still stuck after 2 hours:

When trying to run /PrepareAD on the domain controller it just keeps saying the server is pending a reboot following a windows server role or feature. There's nothing pending so I have no idea what is going on.

I give up. I'll just leave it on CU15 forever.

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

GettnBetter-8602 avatar image
0 Votes"
GettnBetter-8602 answered

I have found that out of date VC runtimes and general Exchange health issues can cause this. Google dpaulson45 healthchecker.ps1, I have found this script or the tasks it performs essential during upgrades.

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

KyleXu-MSFT avatar image
0 Votes"
KyleXu-MSFT answered

@StephenClark-3646

Here are information about: A Restart from a Previous Installation is Pending


If the response is helpful, please click "Accept Answer" and upvote it.
Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.