How to switch from Private to Domain network - Windows server 2019 RODC

Mohd Arif 301 Reputation points

I have created a windows server 2019 RODC, it is working fine. But, it automatically goes to "Private Network". I have other windows server 2012 R2 RODC, they are in "Domain Network". I read some article to restart "Network Awareness Location" service, I did it and then I was switched to Domain Network but started giving login problem, I was not able to login with any domain account in RODC after switching from PVT to domain network. Some how my colleague helped to switch back at PVT network then it started working good.

I need to switch back from PVT network to domain network permanently without any issue, is there any way please???

Windows Server 2019
Windows Server 2019
A Microsoft server operating system that supports enterprise-level management updated to data storage.
3,601 questions
Windows Server
Windows Server
A family of Microsoft server operating systems that support enterprise-level management, data storage, applications, and communications.
12,601 questions
Active Directory
Active Directory
A set of directory-based technologies included in Windows Server.
6,213 questions
{count} vote

Accepted answer
  1. Anonymous

    When NLA starts to detect the network location, the machine will contact a domain controller via port 389. If this detection is successful, it will get the domain firewall profile (allowing for correct ports) and we cannot change the network location profile.
    If the domain was not found or process failed, NLA will let you to determine which firewall profile will be used, private or public.

    The Network Location Awareness (NLA) service expects to be able to enumerate the domain’s forest name to choose the right network profile for the connection. The service does this by calling DsGetDcName on the forest root name and issuing an LDAP query on UDP port 389 to a root Domain Controller. The service expects to be able to connect to the PDC in the forest domain to populate the following registry subkey:
    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\NetworkList\Nla\Cache\IntranetForests
    If something hinders the DNS name resolution or the connection attempt to the DC, NLA is not able to set the appropriate network profile on the connection.

    So I'd check the domain controller and problem client have the static address of DC listed for DNS and no others such as router or public DNS

    --please don't forget to Accept as answer if the reply is helpful--

    6 people found this answer helpful.

2 additional answers

Sort by: Most helpful
  1. Nishant Potdar 81 Reputation points

    I had also faced the same issue. I just disabled and re-enabled the NIC and done!

    4 people found this answer helpful.

  2. Mohd Arif 301 Reputation points

    @Nishant Potdar and @Barry Compton Disabling and enabling of NIC is just a temporary solution. They will not survive any reboot. Also, Restarting of NLA is just temp solution, it won't survive reboot.
    I followed below document and it fixed my problem.

    0 comments No comments