software updates not appearing in Software center

Vijayaguru M 41 Reputation points
2021-03-19T08:43:37.143+00:00

Hi All,

Yesterday we faced some strange issue where the updates not appeared in Software center. We have created a deployment and schedule to install updates to all servers from 7PM and 5AM yesterday. we could see some of 2016 and 2012r2 servers not received updates in software center. There was nothing change in the environment and it was working fine till last month. I have checked the client logs and boundaries, everything seems to be ok. MW is also set correctly either.

Can you please advise on this.

Thanks,
VJ

Microsoft Configuration Manager Updates
Microsoft Configuration Manager Updates
Microsoft Configuration Manager: An integrated solution for for managing large groups of personal computers and servers.Updates: Broadly released fixes addressing specific issue(s) or related bug(s). Updates may also include new or modified features (i.e. changing default behavior).
1,005 questions
0 comments No comments
{count} votes

2 answers

Sort by: Most helpful
  1. SunnyNiu-MSFT 1,696 Reputation points
    2021-03-22T03:34:39.743+00:00

    @Vijayaguru M
    Here is an answer to your question that hopefully you find helpful!
    Based on the above description, it is difficult for us to determine the specific cause.
    1)We may firstly check PolicyAgent.log (C:\windows\ccmsetup\Logs) on the client to see if the policy has been received.
    2)We could try to manually run "Software Updates Scan Cycle" and "Software Updates Deployment Evaluation Cycle" in the SCCM client to make the policy appear in the Software Center faster.
    3)In addition, if somebody else is logged on the device, the deployments won't show up in Software Center. So we may try to check if somebody else is logged on, and disconnect the one.


    If the response is helpful, please click "Accept Answer"and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


  2. Rahul Jindal [MVP] 9,556 Reputation points MVP
    2021-03-23T21:27:57.923+00:00

    Do you see the deployment assignments showing up in the updatedeployment log? Have you double checked the deployment settings for schedule and user experience?