Form Recognizer API Compatibility Error 1027

Rucha Sawarkar 1 Reputation point
2021-03-20T08:13:23.637+00:00

I am getting below error. I have trained my model in labelling tool - https://fott-preview.azurewebsites.net/ .

with open(path_to_sample_content, "rb") as f:
poller = form_recognizer_client.begin_recognize_custom_forms(model_id = model_id, form = f)

When I run the code above getting below error.

HttpResponseError: (1027) The Form Recognizer API version used to create the model and the current API version used for analyze are incompatible.

Azure AI Document Intelligence
Azure AI Document Intelligence
An Azure service that turns documents into usable data. Previously known as Azure Form Recognizer.
1,528 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Ramr-msft 17,731 Reputation points
    2021-03-22T08:55:46.087+00:00

    @Rucha Sawarkar Thanks for the question. Can you please add more details about the trained FR model version and Analyzed API version that you are trying.

    If the model is trained with a different version than the one used for analyze API this message would be seen. You can use the same version of analyze API to ensure the response is successful.