Clipboard integration not working using RD Gateway

Stefan Falk 151 Reputation points
2021-03-22T12:50:19.853+00:00

Hello everybody,

at a customer's site we just set up a new RD server farm. Connecting to it internally works fine including clipboard integration. However, when going throw the RD gateway and RDWeb, the clipboard synchronization does not work. It is activated both in the RD session collection and we can see the clibboard integration checkbox active in the RD client - but it just does not work. What could be the cause please?

Best Regards,
Stefan

Remote Desktop
Remote Desktop
A Microsoft app that connects remotely to computers and to virtual apps and desktops.
3,034 questions
No comments
{count} votes

Accepted answer
  1. Stefan Falk 151 Reputation points
    2021-04-12T15:27:14.413+00:00

    Hello Karlie,

    OMG, I seem to be dumb and blind - my apologies! The checkboxes in the RD gateway rules in the devices tab tell what to forbid, not what to allow. I just reversed everything and now the clipboard - formerly explicitly forbidden instead of allowed - works fine.

    Again, my apologies for being so stupid.

    Best Regards,
    Stefan


5 additional answers

Sort by: Most helpful
  1. Karlie Weng 8,216 Reputation points Microsoft Employee
    2021-03-23T06:41:06.003+00:00

    Hello @Stefan Falk

    Please check if the clipboard redirection has been enabled on RD gateway server.

    On RD Gateway manager> CAP> Device redirection> select enable device redirection for all client devices.

    80467-image.png

    80551-image.png

    Best Regards
    Karlie

    ----------

    If the Answer is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    No comments

  2. Stefan Falk 151 Reputation points
    2021-03-25T11:44:03.773+00:00

    Hello Karlie,

    Thanks for your tip. We had already enabled printer and clipboard redirection in RD Gateway Manager, but it does not seem to work. Where else could something be wrong please?

    Best Regards,
    Stefan


  3. Stefan Falk 151 Reputation points
    2021-04-01T14:33:01.687+00:00

    Hello Karlie,

    We have not set or disabled the "Eneble connection through RD Gateway" policy on any server.

    I tried to connecto through the RD Gateway as you wished, and the clipboard integration does not work. I re-checked that it does work when I connect directly without using the Gateway.

    So the problem seems to be related to the Gateway - but why?

    Best Regards,
    Stefan

    No comments

  4. Karlie Weng 8,216 Reputation points Microsoft Employee
    2021-04-02T02:21:47.793+00:00

    Hi,

    Remote Desktop Connection (mstsc.exe), Local Resources tab, please make sure Clipboard is selected and under More button that Drives is selected.

    And the target host you need to not Disable Drive redirection

    Sometimes unchecked these box and Apply, then checked the box again and hit Apply would work.

    No comments