question

71425117 avatar image
0 Votes"
71425117 asked ZhengqiLou-MSFT commented

Management of automatic activation of mailbox bases in DAG Exhange

Good day!
There is a DAG with two Exchange 2013 nodes. On one server, all databases are active, on the other, all databases are passive.
I want to prohibit automatic database activation on a server with passive databases, i.e. I want to manage the activation of databases manually.

In the documentation, I found three pairs of activation control commands, but I did not quite understand what is the difference between them and which commands should I use in my case?

Suspend-MailboxDatabaseCopy –Identity DB-name \ server-name -ActivationOnly - disable activation
Resume-MailboxDatabaseCopy <DBCopy> - allow activation


Set-MailboxServer <ServerName> -DatabaseCopyAutoActivationPolicy Blocked - disable activation
Set-MailboxServer <ServerName> -DatabaseCopyAutoActivationPolicy Unrestricted - allow activation

Set-MailboxServer <ServerName> -DatabaseCopyActivationDisabledAndMoveNow $ True - disable activation
Set-MailboxServer <ServerName> -DatabaseCopyActivationDisabledAndMoveNow $ False - enable activation

office-exchange-server-administration
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

AndyDavid avatar image
0 Votes"
AndyDavid answered AndyDavid edited

use this command:
Set-MailboxServer <ServerName> -DatabaseCopyAutoActivationPolicy Blocked

Why? Because it does what you want. :)
https://docs.microsoft.com/en-us/powershell/module/exchange/set-mailboxserver?view=exchange-ps



this command stop replication to that database, so only use when performing maintenance on the server and you dont want any replication to occur to it.
So dont use this one:
Suspend-MailboxDatabaseCopy –Identity DB-name \ server-name -ActivationOnly

Only use this when you want to also move any active DBs on that server to another before blocking autoamtic activation

Set-MailboxServer <ServerName> -DatabaseCopyActivationDisabledAndMoveNow $ True



5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

ZhengqiLou-MSFT avatar image
0 Votes"
ZhengqiLou-MSFT answered ZhengqiLou-MSFT commented

Hi @71425117 ,

Agree with Andy, In case your database are all activated on server 1, and you want to manually control the passive copies on server2, blocking the database copy auto activity could best meet your requirements.
81431-image.png
81384-image.png

Regards,
Lou


If the response is helpful, please click "Accept Answer" and upvote it.
Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


image.png (49.9 KiB)
image.png (18.7 KiB)
· 2
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi @71425117 ,

Do the suggestions above help? If the issue has been resolved, please click “Accept as answer” to mark helpful reply as an answer, this will make answer searching in the forum easier and be beneficial to other community members as well.

Regards,
Lou


If the response is helpful, please click "Accept Answer" and upvote it.
Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

0 Votes 0 ·

Hi @71425117 ,

It has been a long time since last reply, did these suggestions help you? If the above suggestion helps, please click “Accept as answer” to mark helpful reply as an answer.Your action would be helpful to other users who encounter the same issue and read this thread.

Regards,
Lou


If the response is helpful, please click "Accept Answer" and upvote it.
Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

0 Votes 0 ·