question

sns1 avatar image
0 Votes"
sns1 asked sns1 commented

user profile issue

I have a small pattern forming. A couple of users that started full time in Jan2021 don’t appear to have email addresses associated with their SP profiles.
If we search them in CA/Manage user profiles the email is blank as below.
Usually I would run a full sync and this sort of thing would clear up. I tried this on the first user and it would not pull from AD. I can see it in AD.
AD connectivity looked good and we didn’t see anything obvious

maybe altering the scheduled time frames for the jobs.?

For the first user I was able to get them working by manually filling in their profile email

Please help 81411-capture.jpg


office-sharepoint-server-administration
capture.jpg (15.9 KiB)
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

AllenXu-MSFT avatar image
0 Votes"
AllenXu-MSFT answered AllenXu-MSFT commented

Hi @sns1 ,

To map E-mail property from AD to Work email(E-mail address) user property in SharePoint, please take a reference to the following steps.

  • Access SharePoint Central Administration -> Manage service applications -> User Profile Service Application -> Manage User Properties.

  • Find Work email user property-> Edit.
    81454-1.png

  • Scroll down to Add New Mapping section on the Edit User Profile Property page -> Select AD source Data connection -> Type mail in Attribute text box -> Click Add -> Click OK.
    81455-image.png
    81408-image.png

  • Start Full Synchronization and wait for completion.

Here is a test result in my end. An user named "ABC" whose e-mail address is ABC@123.COM in AD was mapped to SharePoint as shown below.
81409-image.png
81360-1.png
81410-2.png


If an Answer is helpful, please click "Accept Answer" and upvote it.
Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


1.png (6.9 KiB)
image.png (3.7 KiB)
image.png (5.3 KiB)
image.png (15.2 KiB)
1.png (7.9 KiB)
2.png (5.1 KiB)
· 16
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi @sns1,

Is there any update on this thread? I'm looking forward to your reply.

0 Votes 0 ·

Hi Allen,

we are still looking at you solution, will update once we tested. Thank you for your help,

0 Votes 0 ·

@sns1,

That's OK. Thanks for your response.

0 Votes 0 ·
Show more comments
sns1 avatar image
0 Votes"
sns1 answered sns1 commented

Hi Allen,

Below screenshots are from lab:
I configured as you suggested, however I am noticing user profile sync status coming to IDLE with in 2 minutes and user profile numbers also not changing, so I believe it is not syncing at all. Please suggest how to verify user profile sync service started and run full synchronization successfully?
FYI: it is SharePoint 2016 version both in lab and production
86478-configconnections.jpg86532-connec1.jpg



connec1.jpg (32.8 KiB)
userlogss.txt (22.6 KiB)
· 5
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi @sns1,

You need to Populate Containers and check the check box of the containers contain the users you want to import to SharePoint here:
85649-1.png


0 Votes 0 ·
1.png (19.2 KiB)

Hi Allen,

Did you have a chance to look in to my above response?

0 Votes 0 ·

@sns1,

Make sure you have selected SharePoint ADI here firstly.
86883-image.png

Add or delete a user in your AD server(make sure the new user is in the container of the connection), start full sync, see if the amount of user profile changes.






0 Votes 0 ·
image.png (25.8 KiB)
Show more comments