Cannot delete Azure Databricks workspace

Michael Cameron 21 Reputation points

I have a databricks workspace which I tried deleting, the deletion failed part way through and since then the provisioning state says "Deleting", however, it never actually gets deleted.
No new deletion requests work either, I get an error saying the state is "deleting" and the request fails. It has been in this state for 6 months. It is in my personal subscription so there is no support, I can't open a ticket.

I tried with both the portal and the Rest API with no success.

Any suggestions?

Azure Databricks
Azure Databricks
An Apache Spark-based analytics platform optimized for Azure.
1,391 questions
0 comments No comments
{count} votes

Accepted answer
  1. KranthiPakala-MSFT 39,002 Reputation points Microsoft Employee

    Hi MichaelCameron-3386 ,

    Welcome to Microsoft Q&A and thank you for your query.

    You issue seems similar to below issue.

    I would recommend to clear your browser cache, restart browser and then try deleting your Azure Databricks service in incognito/private browser.

    If that doesn't help to resolve your issue, please send an email to with the below details, so that we can enable a one-time-free support for you to work closely on this matter.

    • Email subject: <Attn - Kranthi : Microsoft Q&A Thread title>
    • Thread URL: <Microsoft Q&A Thread link>
    • Subscription ID: <your subscription id>

    Please let me know here once you have done the same.

    Thank you

    Please do consider to click on "Accept Answer" and "Upvote" on the post that helps you, as it can be beneficial to other community members.

1 additional answer

Sort by: Most helpful
  1. Michael Cameron 1 Reputation point

    After posting here I emailed Kranthi via the address above. My subscription was enabled for a one time support request, I rasied a ticket and it was fixed. I know I had to mark the message for his attention, if he has moved on I don't know who to send it to, sorry.