question

AndreaBonomi-1069 avatar image
0 Votes"
AndreaBonomi-1069 asked AndreaBonomi-1069 answered

Server 2012 R2: Cannot Install .Net Framework 4.7.2 or 4.7.1 .Net Framework for exchange upgrade from cu 19 to 23




OS: Windows Server 2012 R2 with exchange 2013 cu 19

I can't install .NET Framework 4.7.2, or any Windows updates for .NET Framework for upgrading my Exchange server 2013

I tried with Dism to repair store but any time receive store is ok, I receive this error when I run 4.7.2 package.

When running both the .NET Framework 4.7.1 and 4.7.2 offline installers, I get

Exe (S:\55be9ef7754b77f6655f22b680bb\x64-Windows8.1-KB4054566-x64.cab) failed with 0x3712 - The component store has been corrupted. .
Exe Log File: CBS.log
PerformOperation on exe returned exit code 14098 (translates to HRESULT = 0x3712)
Action complete
Error 0x3712 is mapped to Custom Error:
OnFailureBehavior for this item is to Rollback.
Action: Performing actions on all Items
Restart manager will not be used since the current operation is not install.
Action complete
Action complete
Final Result: Installation failed with error code: (0x00003712), "The component store has been corrupted. " (Elapsed time: 0 00:02:37).

Can someone please tell me something?

Thanks!

dotnet-runtime
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

GettnBetter-8602 avatar image
0 Votes"
GettnBetter-8602 answered

Google dpaulson45 healthchecker.ps1. This script or the tasks it performs can help expose the issues that need resolved

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

GettnBetter-8602 avatar image
0 Votes"
GettnBetter-8602 answered

OOp also, I remember from past installs that sometimes it is necessary to uninstall or downgrade modern versions of .Net. In this case however, Cu19 requires .Net 4.8. Try installing 4.8, then CU 23

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

AndreaBonomi-1069 avatar image
0 Votes"
AndreaBonomi-1069 answered

Hi
I treid with 4.8. the same error.
Cu19 requires .net 4.62 or 4.71.
I would update to 23 for hafnium patch
thank u


5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.