question

LisaLownds-9214 avatar image
1 Vote"
LisaLownds-9214 asked prmanhas-MSFT edited

Error with PowerShell cmdlets

Folks,
I've recently started getting errors in PowerShell e.g. "WARNING: MSG:UnableToDownload «https://go.microsoft.com/fwlink/?LinkID=627338&clcid=0x409» «»" and "WARNING: Unable to download the list of available providers. Check your internet connection."

I can run the TLS fix I found on another forum but it is not persistent. Any ideas?

Lisa.

9305-powershellerror.jpg


not-supported
powershellerror.jpg (116.3 KiB)
· 3
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

@LisaLownds-9214

Please 'Accept as answer' if the provided information is helpful, so that it can help others in the community looking for help on similar topics.

0 Votes 0 ·

Not seeing how I 'Accept as answer' but it is answered.

Lisa.

0 Votes 0 ·

@LisaLownds-921

You can accept the answer that helped you, by clicking Accept which you will find to the end of the Answer. Below screenshot for your reference.

9671-accept-answer.jpg


0 Votes 0 ·
accept-answer.jpg (16.1 KiB)
ManuPhilip avatar image
1 Vote"
ManuPhilip answered ManuPhilip edited

Hello @LisaLownds-9214,


TLS fix you mentioned is a workaround for the issue. You may follow the steps below for a permanent solution by a registry value adjustment


Open Powershell and check for supported protocols by using[Net.ServicePointManager]::SecurityProtocol


Run the following 2 cmdlets to set .NET Framework strong cryptography registry keys:


Set strong cryptography on 64 bit .Net Framework (version 4 and above)


Set-ItemProperty -Path 'HKLM:\SOFTWARE\Wow6432Node\Microsoft.NetFramework\v4.0.30319' -Name 'SchUseStrongCrypto' -Value '1' -Type DWord



set strong cryptography on 32 bit .Net Framework (version 4 and above)


Set-ItemProperty -Path 'HKLM:\SOFTWARE\Microsoft.NetFramework\v4.0.30319' -Name 'SchUseStrongCrypto' -Value '1' -Type DWord



Restart Powershell and check again for supported protocol by using [Net.ServicePointManager]::SecurityProtocol


Please mark as "Accept the answer" if the above steps helps you. Others with similar issues can also follow the solution as per your suggestion


Regards,


Manu


5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

LisaLownds-9214 avatar image
0 Votes"
LisaLownds-9214 answered ManuPhilip commented

@ManuPhilip thanks. I read that in the article when I found the fix. However, I am now curious to know why I need to do this and what has changed?


Lisa


· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hello Lisa,

You have probably noticed warnings on various websites about services removing support for TLS 1.0 and 1.1. PowerShell latest versions defaults to only enabling SSL3 and TLS 1.0 for secure HTTP connections. Thus the Provider list at the URL cannot be accessed and install fails. So, we manually forcing to use strong crypto by this method. Hope, this helps !

Thanks,
Manu

1 Vote 1 ·