Visual Studio 2019 Cloud Explorer MFA authentication not working

Alex St-Laurent 21 Reputation points
2020-06-08T23:05:18.58+00:00

Since updating my VisualStudio 2019 to 16.6.1 I'm having issues trying to authenticate to acces the Clound Explorer. I'm not saying this is related to the 16.6.1 version but I started having the issue right after the update. I did not however use the cloud explorer during that day prior to the update, but it worked fine 3 days before.

The problem is that I am logged in with my Office 365 account into Visual Studio and the Cloud Explorer also shows me that account. The cloud explorer however keeps showing "Reenter credentials" under said account. That is not uncommon and usually I simply reenter my credentials, approve the request on the authenticator app and then the cloud explorer loads fine and I can access my resources without any problem.

Since today though every time I try to reenter my credentials, the authentication window asks for the authentication code, which is strange because my selected method of MFA authentication is the approval notification... If I actually try to enter a code, it does not work. If I choose to change the method to the approval notification, I never receive it. Its almost as if they actually are not the same account but I did a password reset and they now definitely need the same password, they are the same account.

I can't event use the menu "Help->Send Feedback->Report a problem" because as soon as log in the popup window that it opens on "developercommunity.visualstudio.com" I get logged out. Really feel that something is wrong with my account. Even tried installing VS on another machine and I get the same issue.

Everything else works fine and uses the right MFA method. Outlook, OneDrive, TEAMS, Office 365, portal.azure.com, Azure DevOps...

I ablosutely don't understand what is happening or even where to start.

This is completely preventing me to use the cloud explorer to attach to my appservice in Azure.

9421-untitled.jpg

Microsoft Entra ID
Microsoft Entra ID
A Microsoft Entra identity service that provides identity management and access control capabilities. Replaces Azure Active Directory.
20,447 questions
0 comments No comments
{count} votes

Accepted answer
  1. Anonymous
    2020-06-09T00:09:22.043+00:00

    Visual Studio is not currently supported here on QnA. I'd try asking for help in dedicated forums here.

    https://social.msdn.microsoft.com/Forums/vstudio/en-US/home?forum=visualstudiogeneral

    https://developercommunity.visualstudio.com/spaces/8/index.html

    --please don't forget to Accept as answer if the reply is helpful--


    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows Server] Datacenter Management

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees, and confers no rights.


4 additional answers

Sort by: Most helpful
  1. Andrew Foulk 11 Reputation points
    2020-09-15T15:43:11.763+00:00

    I am having this exact same problem still. Every time I enter the authenticator code, it doesn't accept it, so i am still unable to sign in to cloud explorer, using "Report a problem" or anything that tells me to "reenter credentials"

    1 person found this answer helpful.
    0 comments No comments

  2. Alex St-Laurent 21 Reputation points
    2020-06-09T00:14:43.003+00:00

    Ok I'll accept your answer and try to post somewhere else.
    As mentioned I can't even post in https://developercommunity.visualstudio.com/spaces/8/index.html as I have to do it through VS and it won't let me :P

    Thanks

    0 comments No comments

  3. Volker (MSFT) 1 Reputation point Microsoft Employee
    2021-01-12T20:49:21.897+00:00

    Same for me and really very annoying - no problem with Win Credentials but only w/ VS 2019 :-/

    0 comments No comments

  4. Ana Cristina Stefan 1 Reputation point
    2021-11-22T16:16:42.097+00:00

    hello,
    Has anyone find a solution for this yet?
    Thanks

    0 comments No comments