question

BangMinah-2170 avatar image
0 Votes"
BangMinah-2170 asked OlgaOS-msft commented

Can't connect to my with error code 0x104

I can't connect to my VM as 30 March 2021
As I remember it was fine before, because I can use my VM last night before I sleep (29 March 2021)

This is my exact problem when connecting to my VM using Remote Desktop Connection from my Windows 10
https://docs.microsoft.com/en-us/answers/questions/209198/azure-vm-access.html

I've tried the solution that listed : https://docs.microsoft.com/en-us/azure/virtual-machines/troubleshooting/troubleshoot-rdp-nsg-problem

When I use my phone to connect, it says error code 0x104

I've tried to Restart my VM 3 times
And Redeploy 1 time
But still can't connect

VM location : South East Asia
Current subscription : Azure Students with $100 credits



azure-virtual-machines
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

1 Answer

OlgaOS-msft avatar image
0 Votes"
OlgaOS-msft answered OlgaOS-msft commented

I am sorry to hear you lost connection to your VM.

Error message what you posted above is the general one and could have many root causes.

Did you do any changes on the VM before you lost connection?

First, I'd check if VM is fully booted. If you cannot connect to your Windows virtual machine (VM) and are unsure of the cause, you can start by accessing the Boot Diagnostics Screenshot for your VM and determine if the VM is experiencing a boot error.

82508-image.png


If your VM is not at the ctrl-alt-del screen, it may be experiencing a boot error

  1. Restart the virtual machine to address boot issues by clicking Restart at the top of the VM resource blade

  2. If your VM fails to start and you recently applied Windows Updates please see Troubleshooting VM not booting after Windows Update

  3. Review the common boot errors and solutions for non-bootable VMs troubleshooting guide

VM is at the ctrl-alt-del screen - issues external to the VM (Load Balancer, NSG, ExpressRoute)

Use Network Watcher to help diagnose connectivity issues to your VM.

VM is at the ctrl-alt-del screen - issues internal to the VM

  1. Resetting your VMs RDP configuration here or by following instructions in the guide: Reset Remote Access to address RDP issues using PowerShell or CLI

  2. If your VM has booted into Safe Mode, follow VM boots into Safe Mode

  3. If you are seeing a red X over the network icon on the screenshot, follow Cannot connect due to netvsc.sys issue

  4. If your network interface card (NIC) in the guest OS may be disabled or misconfigured, follow NIC disabled in guest OS

  5. Verify if the guest OS firewall is misconfigured

  6. Disable the guest OS Firewall in Azure VM

  7. Enable or disable a firewall rule on an Azure VM Guest OS

  8. Azure VM Guest OS firewall is blocking all inbound traffic

If you still are encountering RDP errors

  1. Basic RDP Troubleshooting in Azure VMs

  2. Troubleshooting general RDP errors in Azure VMs

  3. The Remote Desktop license server is not available when you connect via RDP to an Azure VM

  4. Review the common RDP errors and solutions for Azure VMs

Hope above information is good for you to resolve the issue.


image.png (310.9 KiB)
· 2
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Thank you for the details, I will try

1 Vote 1 ·

Hello @BangMinah-2170! Please kindly let me know if you were able to resolve the issue and what step helped you.

0 Votes 0 ·