question

Kirill-0480 avatar image
0 Votes"
Kirill-0480 asked DaisyZhou-MSFT edited

ACtive directory Web Services unable to start

Hello everyone

After reboot there is a problem with ADWS service. It always starting with error :
A timeout was reached (60000 milliseconds) while waiting for the Active Directory Web Services service to connect.

There are no any events in Active Directory Web Services - Application and Services Logs

Tried to turn on additional logs - no event at all
https://techcommunity.microsoft.com/t5/ask-the-directory-services-team/active-directory-web-services-event-1202/ba-p/1514401

Checked:
1) Certificate is valid and can be enrolled
2) dism checkhealth and sfc /scannow
3) Procmon - no access denied or some other error, except
Microsoft.ActiveDirectory.WebServices.exe Operation - TCP Reconnect take too much time and ended with TCP Disconnect

What else can i do ?

windows-active-directory
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

DaisyZhou-MSFT avatar image
0 Votes"
DaisyZhou-MSFT answered

Hello @Courtenay-9443,

Thank you for posting here.

After my view, I can see "Active Directory Web Services---This service provides a Web Service interface to instances of the directory service (AD DS and AD LDS) that are running locally on this server. If this service is stopped or disabled, client applications, such as Active Directory PowerShell, will not be able to access or manage any directory service instances that are running locally on this server."

1.Based on the description, do you mean the ADWS service on one Domain Controller can not be started?
2.If so, if you try to start ADWS service on this Domain Controller, what error message do you receive? Please provide the screenshot if possible.
3.After we try to start ADWS service on this Domain Controller (maybe the service can not be started), please check if there is any event logged in Event Viewer as below?
83820-adlds.png


Should you have any question or concern, please feel free to let us know.


Best Regards,
Daisy Zhou



adlds.png (48.7 KiB)
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Kirill-0480 avatar image
0 Votes"
Kirill-0480 answered

Hello Daisy,

Thank for response

1) Yes, ADWS service can not be started on one Domain Controller. Others work well. Btw, DC is Windows Server 2012 R2
2) Errors always the same

The Active Directory Web Services service failed to start due to the following error:
The service did not respond to the start or control request in a timely fashion.

A timeout was reached (60000 milliseconds) while waiting for the Active Directory Web Services service to connect.
83981-image.png



3) There are no any events at all on Active Directory Web Services Logs after it stop to working. Even after computer restart.


image.png (27.5 KiB)
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

DaisyZhou-MSFT avatar image
0 Votes"
DaisyZhou-MSFT answered

Hello @Courtenay-9443,

For event ID 7000, we can refer to the link below.

A slow service does not start due to time-out error in Windows
https://docs.microsoft.com/en-us/troubleshoot/windows-server/system-management-components/service-not-start-events-7000-7011-time-out-error

Then check if the issue persists.

Should you have any question or concern, please feel free to let us know.


Best Regards,
Daisy Zhou

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Kirill-0480 avatar image
0 Votes"
Kirill-0480 answered DaisyZhou-MSFT edited

Hello Daisy,

I've tried to increase time to 120 seconds and restart computer Already, it doesn't help.
Service fall in 20 seconds

kind regard
Kirill

· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hello @Kirill-0480,

Thank you for your update.

1.When did this problem happen?

2.Have you made any changes to this domain controller before this problem occurred? For example, a patch was recently installed on this domain controller or other changes.

We can run Wmic qfe list >C:\Hotfixes.txt on all DCs to compare.

Should you have any question or concern, please feel free to let us know.



Best Regards,
Daisy Zhou

0 Votes 0 ·
Kirill-0480 avatar image
0 Votes"
Kirill-0480 answered DaisyZhou-MSFT edited

Hello Daisy,

  1. After updates unstallation and reboot

  2. All last installed patches were removed. There where no any other changes

kind regard
Kirill

· 3
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hello @Kirill-0480,

Thank you for your update.

I suggest you can add a new DC to this domain and remove this DC from the domain.

Or if you must fix this issue, considering that your problem may be a bit complicated and cannot be solved by general methods, it may need to collect logs for further analysis and troubleshooting. I suggest you submit a service request to MS Professional tech support service so that a dedicated support professional can further assist you with this request.

The following web site for more detail of Professional Support Options and incident submission methods is for your reference:

https://support.microsoft.com/en-in/gp/contactus81?forceorigin=esmc&Audience=Commercial

https://support.microsoft.com/en-us/help/4051701/global-customer-service-phone-numbers

Thank you for your understnading and support.


Best Regards,
Daisy Zhou

0 Votes 0 ·

Hello Daisy Zhou,

Thank you for your help.
I've found the problem - it was connected with third party security application, that is installed at all others DCs and work without problem. After uninstall this application service start to work.
I'll raise an request to the venor support.

0 Votes 0 ·

Hello @Kirill-0480,

Thank you for your update and sharing.

I am very glad that the problem has been solved.

As always, if there is any question in future, we warmly welcome you to post in this forum again. We are happy to assist you!


Best Regards,
Daisy Zhou

0 Votes 0 ·