question

MariusCarciumaru-9729 avatar image
0 Votes"
MariusCarciumaru-9729 asked CarlFan-MSFT answered

RDS 2019 Deployment

Hi there

We have deployed a new RDS farm with 5 RDS Hosts, 1 RDS Broker (broker and licensing role) and RDS WEB (not configured yet, for future)

For load balancing we use for the time DNS RR. It has worked great in the past for the TS 2008 R2 farm.
All 5 RDS hosts, have static ip and the FARM points to the each IP of the RDS HOSTS.

We defined the collection accordingly, gave it the same name as the farm name (without the local domain name) .
Recently, at random times and random users, we get an error that states: "Remote Desktop Connection cannot verify that the two remote computers belong to the same farm...." and points to the name of one specific host. That RDS Host , is already a member of the farm , so not sure why would this happen.
My only suspicion so far is that we asked our users to open the rdp using the fgdn, like farm.domain.local
Not sure if we should try in the rdp just farm and let DNS to its magic.
i feel this is a cheap shot . We cant replicate it all the time.
It will happen once, and all of a sudden second attempt works.

Any ideas ? Things we missed ?

remote-desktop-servicesremote-desktop-client
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

1 Answer

CarlFan-MSFT avatar image
0 Votes"
CarlFan-MSFT answered

Hi,
Firstly, I suggest that check for update. If any security updates could be found, please install. It could make sure to update system files.
I consider that if it has something to do with the names of the servers not being added in DNS
make sure DNS is updated and then also do a ipconfig /flushDNS
Meanwhile some settings you may could check:
1.Log into RDS Host Configuration, open RD Connection Broker settings and ensure that ‘Participate in Connection Broker Load-Balancing’ in selected.
2.Changing the Security layer to RDP Security Layer (Session Host Configuration -> RDP-Tcp Properties -> Security Layer
changed it back to Negotiate security to check.
Hope this helps and please help to accept as Answer if the response is useful.
Best Regards,
Carl

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.