question

ErshovIS avatar image
0 Votes"
ErshovIS asked ErshovIS answered

RD Gateway custom port

I am setting up RD Gateway on Windows Server 2019 to run on non-default port.
Settings applies, i can see correct bindings in IIS site and active listening port on the server. Also checked registry values - all correct
But clinet connection from Windows 10 RDP client with RD Gateway serverFQDN:port fails (with default 443 port connection successfull).
New custom port is available, I can access it via telnet
IIS Site opens on new custome port
Any ideas?

remote-desktop-services
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

ErshovIS avatar image
0 Votes"
ErshovIS answered

The issue resolved with this registry entry
[HKEY_CURRENT_USER\Software\Microsoft\Terminal Server Client]
"RDGClientTransport"=dword:00000001

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

CarlFan-MSFT avatar image
0 Votes"
CarlFan-MSFT answered

Hi,
Have you checked the settings below:
Add Inbound Firewall rule for YourCustomPortValue
Regedit

[HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\TerminalServerGateway\Config\Core]

IsUdpEnabled REG_DWORD 0


Cmd

net stop tsgateway && net start tsgateway


Regedit

[HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\TerminalServerGateway\Config\Core]

HttpsPort REG_DWORD (YourCustomPortValue)

Cmd

net stop tsgateway && net start tsgateway
Hope this helps and please help to accept as Answer if the response is useful.
Best Regards,
Carl

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.