45669932 avatar image
0 Votes"
45669932 asked 45669932 commented

Reg-Free, Side by Side configuration, Resource Type #24, ID 1

Visual Studip 2019, VB.

I have, after trial and error, been able to generate a side-by-side project with appropriate manifests using an ocx file as a resource. This works in debug mode and production mode on my Win 10, but not on my client's server. The client's server events states "Faulty Module Path" and lists the path and ocx file located in the same directory as the application's exe file.

I have covered every step through numerous references with the exception of one: A few references state to load the resource as a Type #24 and ID 1, with examples from VB6 for this "simple change" in the resource manager. There is no resource manager in VS 2019.

I cannot find where this change is made in Visual Studio 2019. Can anyone assist?

· 4
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Additional note: I have unregistered the ocx from the windows registry on my Win 10 and on the client's server. I have removed the ocx file from the SysWOW64 directory on both machines, with the application working on my machine and still not working on the client's server.

0 Votes 0 ·

Ok, another strange occurrence: The app runs on the client's server from a command prompt but not from a service I have installed which calls it. The service calls about 28 other programs without an hindrance or errors. When the service calls this app, nothing happens and the server application event states "Faulty Module Path" and lists the path and ocx file located in the same directory as the application's exe file - yet it runs from the command prompt?

This may be less to do with the resource type and ID and more to do with how the program starts on the server. I'm still lost as to why it runs from the command prompt and not via the window's service which calls it?

Any thoughts or pointers in the right direction will be sincerely appreciated.

0 Votes 0 ·

Update: Today I tried changing the windows service from "local service" to "network service". No change. Same result. Same event error.

0 Votes 0 ·

Update: Worked on this all week. Thought it might have something to do with the ocx driver not liking session0, which is where I believe it would run if started by the local service. Tried Powershell and psexec to get it to start in session1 or session 2, both active sessions when running the service. Same results. If I run the same commands in powershell, it works perfectly. Anyone? Please?

0 Votes 0 ·

0 Answers