question

ItsKoda avatar image
0 Votes"
ItsKoda asked XiaoweiHe-MSFT commented

Hyper-V doesn't have a valid IP configuration (External Network VSwitch)

I've followed a ton of threads on how to make this work but for some reason the Hypervisor just can't get internet access...
84614-image.png
84623-image.png
84584-image.png
84615-image.png


windows-server-hyper-v
image.png (4.3 KiB)
image.png (42.8 KiB)
image.png (56.6 KiB)
image.png (31.1 KiB)
· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi,

I would like to check if the reply could be of help? If yes, please help accept answer, so that others meet a similar issue can find useful information quickly. If you have any other concerns or questions, please feel free to feedback.

Best Regards,
Anne

0 Votes 0 ·
DSPatrick avatar image
0 Votes"
DSPatrick answered ItsKoda commented

Please post an unedited ipconfig /all of both something working and this problem one.




· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

84642-image.png
Broken Hyper-Visor



84652-image.png
Working Server


0 Votes 0 ·
image.png (108.5 KiB)
image.png (227.7 KiB)
DSPatrick avatar image
0 Votes"
DSPatrick answered ItsKoda commented

169.254,xxx,xxx addresses are APIPA. Looks like a DHCP server cannot be reached. You may need to configure a static ip address if there's no DHCP server at the site.




· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Where will I find the Static IP that I will need to set it to?

0 Votes 0 ·
DSPatrick avatar image
0 Votes"
DSPatrick answered ItsKoda commented

What roles will be on the VM? Set it to a static address on the desired network. (I'd assume it will be the same network the external vSwitch is plugged into)


· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Just gonna have Routing & Remote Access, and yes its on the same network as the vSwitch is plugged into, I'm just confused on what static address I'm supposed to set it to

0 Votes 0 ·
DSPatrick avatar image
0 Votes"
DSPatrick answered ItsKoda commented

Then I'd assume it will be the same network the external vSwitch is plugged into.


· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Yeah I've tried using the correct details in the adapter and also tried setting up a DHCP server on the master server, still doesn't want to work...

0 Votes 0 ·
DSPatrick avatar image
0 Votes"
DSPatrick answered ItsKoda commented

Maybe this one helps if that's what you're trying to do.
https://www.altaro.com/hyper-v/how-to-install-configure-tcpip-routing-in-a-hyper-v-guest/




· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

I'm no longer getting the original ping error, I don't know if this is a step forwards or backwards...
I followed the doc and it has gotten me this far, I can't go further since there's no internet connection which prevents me from installing the roles...
84653-image.png


0 Votes 0 ·
image.png (17.4 KiB)
DSPatrick avatar image
0 Votes"
DSPatrick answered

If that's the network you want then the gateway (from above) appears to be 51.161.132.254





5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.