question

RickSomeone-1151 avatar image
0 Votes"
RickSomeone-1151 asked SimonRenMSFT-3639 commented

Disable Internet on Hyper-V VM during upgrade.

I need to upgrade my VM via an ISO I modified to remove unwanted stuff (mostly apps).

How can I upgrade this VM to the new OS without internet connection, so that the apps don't re-appear?
If they do, then I'm stuck right where I was, with my sysprep breaking because of this POS apps.

I have a virtual network between my VM and the MDT Server which I need, but I don't want the VM to have any ability to go beyond that, outside to the internet.
I do not know how to disable the VM internet access but retain the local Virtual Connection to the server.
Any ideas?

mem-mdt
· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

I have set the connection to internal, so the VM connect to the Host on the same server.
I can c$ into the server, the E: and the MDTDeploy Share, then into the scripts folder to where I can launch the LiteTouch.vbs

When I click on it, it tells me the connection cannot be made, Connection ok. Possible bad credentials.
Since its internal, I am not using any AD creds, just those local to the server.

Any guess as to why I can get into the Scripts folder, but not launch the LiteTouch to get me to the Deploy?
This is where I need to upgrade my VM without hitting the network and pulling down any apps.

0 Votes 0 ·
SimonRenMSFT-3639 avatar image
0 Votes"
SimonRenMSFT-3639 answered SimonRenMSFT-3639 commented

Hi,

Thanks for posting in Microsoft MECM Q&A forum.

When you update a computer running Windows 10, version 1703 or 1709, you might see provisioned apps that you previously removed return post-update. This can happen if the computer was offline when you removed the apps. This issue can occur whether you removed the app using Remove-appxprovisionedpackage or Get-AppxPackage -allusers | Remove-AppxPackage -Allusers. This issue was fixed in Windows 10, version 1803.

For more information, please refer to: How to keep apps removed from Windows 10 from returning during an update

Thanks for your time.
 
Best regards,
Simon


If the response is helpful, please click "Accept Answer" and upvote it.
Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


· 9
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

I'm using an ISO to try the upgrade now after the reg import.

I wasn't sure if I should use the ISO or just go for the Feature Update from Updates to get to 20H2, if there was any major difference in the outcome.

0 Votes 0 ·

I followed all of those steps. I ran the reg keys for provisioned apps.
Then I used the unchanged ISO for 20H2 and upgraded my VM. It is 20H2.
I ran the VM through the Sysprep & Capture Task in my Build deploy only to have it repeatedly and
endlessly fail with Windows Cortana remaining. I tried running it on the upgraded VM but it seems to remain.
I disabled it in the local GPO as well.

remove-appxpackage - package Microsoft.Windows.Cortana_1.13.0.18362_neutral_neutral_cw5n1h2txyewy
doesnt work

Get-AppxPackage Cortana | Remove-AppxPackage
nope

Remove-AppxProvisionedPackage -Online -PackageName <packagefullname>

Nothing.
Finally did get rid of Cortana, and now BingWeather is a POS. That was listed in the apps to delete. At this point it is going to be running sysprep as many times as needed until no more apps are breaking this.
No one has time for that.

0 Votes 0 ·

So after removing all the apps with the scripts, then upgrading the VM, I still get the same apps errors breaking sysprep. Now this time its BingWeather. Its one after another and none of the scripts to remove them work.

So I'm asking if anyone knows how to sysprep this VM that was 1703, the apps (supposedly but not) removed, then upgraded to 20H2 and still have all the apps.....how does someone get past this?

0 Votes 0 ·

Hi,

Thanks for your reply.

There is no difference between using ISO and Feature Update to upgrade the OS. Per my persional experience, we may try to firstly build a fresh Windows 10 20H2 VM or upgrade your Windows 10 1703 to 20H2, and remove all the unwanted apps, then capture the reference image, to see if there any issues.

If possible, please try to remove the package for the user who's running sysprep, and also remove the provisioning. For more information, please refer to:
Sysprep fails after you remove or update Microsoft Store apps that include built-in Windows images

Best regards,
Simon



0 Votes 0 ·

I will give this one more go...

The instructions in the link you sent say to remove the apps FIRST, then upgrade.
Or is it upgrade then remove the apps?

This is such confusion to know whether the apps are coming back form the new ISO.
However, I've done both. Removed the apps, then upgraded. During sysprep it kept bombing
due to one app then another then another.

So, I upgraded, then ran every app on the web to remove those apps, and sysprep still bombs
because of all the apps in the list I just "removed".
That link also says:

The apps might reappear if you removed the packages in one of the following ways:
•If you removed the packages by running a PowerShell cmdlet on the device while Windows was online.

So I am running the PS scripts and the upgrade off the network in an internal communication with the server....so lets see how this ends up.

0 Votes 0 ·

Nope. Nothing that I've read or found online gets this image sysprepped.
Removing apps, upgrading....upgrading, removing apps....registry changes to stop the
apps from reinstalling.
Nothing provided allows this VM to sysprep. I even set the connection to Internal so the VM would only
talk to the server and not have outside connection ability.
ALL of the apps that any PS job ran to remove the apps just doesn't remove them.

0 Votes 0 ·

Hi,

Thank you very much for your hard work and feedback.

This is a complex issue. I will do more research, if there is any update, I will let you know. Thanks for your understanding.

Best regards,
Simon

0 Votes 0 ·
Show more comments
RickSomeone-1151 avatar image
0 Votes"
RickSomeone-1151 answered

For DanielRogers672-5117,

        Reading this post and the conversations, I couldn't mark anything as a solid answer because I still cannot Capture this image because of MS apps. So, with that said, "the only solution to winning the game is not to play at all."

I'm having our development team rebuild their VM image with 20H2 and not dealing with an upgrade.

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.