question

JiminByun-8420 avatar image
0 Votes"
JiminByun-8420 asked JiminByun-8420 edited

Hyper-V virtual switch keeps choosing the inactive NIC

Hi,

I am having a problem of connecting the host NIC to the External Virtual Switch.

My host laptop for some reasons has multiple NICs. The active NIC which was connected to the internet and given IP address was first the [ Qualcomm Atheros QCA61x4A Wireless Network Adapter ].

So I tried connecting this Qualcomm NIC to the External Virtual Switch but error was prompted saying [ error applying virtual switch properties changes adding ports to the switch failed the operation failed because the object was not found ] and the host lost the internet connection. So I rebooted,

And then, there is a new NIC came up named [ Microsoft Network Adapter Multiplexor Driver ] and now this NIC is active.

I only can choose [ Intel(R) Ethernet Connection I219-V ] for the External Virtual Switch but VMs has still no internet connection.

I removed all the Wireshark and Npcap. But It wasn't fixed.

*** These are the NICs installed in the host.
85032-devicemanager.png


*** These are the NICs I can choose for the Hyper-V virtual switch

85052-hyper-v-network.png

*** But I only can choose the [ Intel(R) Ethernet Connection 1219-V ] but VMs has no internet connection

*** If I choose other NICs there is an error prompted and the host lose the internet connection

85071-error.png

85013-host.png

How can I solve this problem?




windows-10-hyperv
devicemanager.png (23.8 KiB)
hyper-v-network.png (30.6 KiB)
error.png (34.7 KiB)
host.png (40.6 KiB)
hyper-v-network.png (30.6 KiB)
· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi,
I would like to check if the reply could be of help? If yes, please help accept answer, so that others meet a similar issue can find useful information quickly.

If you have any other concerns or questions, please feel free to feedback.

Best regards
Joann

0 Votes 0 ·
jiayaozhu-MSFT avatar image
1 Vote"
jiayaozhu-MSFT answered

Hi,

Thank you for your posting!

Based on your descriptions, I would like to suggest you to firstly take a quick troubleshooting:

1) Try to delete the bridge and the vSwitch on your Wifi card (if the card is not used eh), and then create it again. But this time, please try to create your external network switch via PowerShell commands:

New-VMSwitch -Name “ExternalVirtualSwitch” -NetAdapterName “D-Link02” -AllowManagementOS $True

Note: ExternalVirtualSwitch is the name of the External Virtual Switch you want to name. D-Link02 is the physical network adapter name bind to the External Virtual Switch. Adjust them accordingly.

2) Uncheck the option "Share the NIC with management OS" in virtual switch properties:
85155-case6789.jpg


Here are some other ways for you to have a try:
https://appuals.com/error-applying-hyper-v-virtual-switch-properties/

(Please note: Information posted in the given link is hosted by a third party. Microsoft does not guarantee the accuracy and effectiveness of information.)

You can also take a look at this forum in which the issue is similar with yours:

https://docs.microsoft.com/en-us/answers/questions/302635/hyper-v-create-external-virtual-switch-issue.html

Finally, you can try to create an internal switch to setup a network share to use the Internet:

1)Create a new Virtual Switch - Internal Switch

2)Navigate to Network & Sharing Center and make sure your new Adapter/Virtual Switch is there.

3)Go back to Hyper-V Manager and while your VM is turned off go to Settings -> Add New Hardware -> Legacy Network Adapter and click Add then select OK to Save changes.

4)Now Go back to Network & Sharing Center and select Wi-Fi, select Properties

5)Under the Sharing tab, select the checkbox for 'Allow other network users to connect through this computer's Internet connection' then in the dropdown select the Virtual Switch you created at the start.

6)Click Close and exit.

Your VM should now be able to access your Wireless Adapters network & the internet if it has access.

Thank you for your time!

Best regards
Joann


If the Answer is helpful, please click "Accept Answer" and upvote it.

Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


case6789.jpg (54.9 KiB)
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

JiminByun-8420 avatar image
0 Votes"
JiminByun-8420 answered JiminByun-8420 edited

Hi Joann,

Thank you for a whole lot of information! Awesome.

I resetted network connections by using ‘netcfg -d’ and rebooted,
I reenable Hyper-V manager and rebooted,
I reintalled NICs at the device manager and rebooted,
every step above, I made Virtual Switch through Powershell.
Nothing worked.

But the last resort worked with the [ Solution 6 ] from the link below you gave me.
https://appuals.com/error-applying-hyper-v-virtual-switch-properties/

I have one more question.
It seems that I can't use the Wi-Fi network for the External Virtual Switch because I kept receiving this error message "can't find the object", (which is connected to Wi-Fi and I was going to use for the external switch).

87015-powershell-error.png




Thank you.


5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.