question

spratshell-0193 avatar image
0 Votes"
spratshell-0193 asked EmmeRaba-7999 commented

SCOM Notification Channel not executing Powershell script

We have a SCOM Command Notification channel that executes a
powershell script to send notifications to contacts.


This worked fine until we experienced some network issues and now
the script is not getting executed.


We can manually start the script on the SCOM server with no problems.
When an alert gets generated, however, the script is not getting executed.


The parameters on the channel look like this:


Full Path of the command file:
C:\Windows\System32\WindowsPowerShell\v1.0\powershell.exe
Command line parameters:
-command D:\Scripts\Operational\Live\NotifyScript.ps1 '$Data/Context/DataItem/AlertId$' '$MPElement$'
Startup folder for the command line:
D:\Scripts\Operational\Live\


![83314-image.png][1]


We have restarted the SCOM servers, but nothing changed.


Without log information from the channels, there doesn't seem to be any
way to troubleshoot.


Can someone help us figure out what else we can look at or try please?

Thanks so much!





windows-server-powershellmsc-operations-manager
image.png (126.5 KiB)
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

1 Answer

StoyanChalakov avatar image
1 Vote"
StoyanChalakov answered EmmeRaba-7999 commented

Hi,

had a similar case recently. If you have more than one management server, please make sure you have the same folder structure and the script in the folder on all of the management servers (part of the All Management Servers Ressource Pool). Try again aftewards!

If you have done this already, please filter the Operations Manager Event Logs on all your Mgmt Servers and look for a related event, there should certainly be one out there. Wjhat does it say?

Please also try setting up the Execution Policy to Unrestricted as in this example:

Send SCOM Alerts to Slack
https://www.cookdown.com/blog/send-scom-alerts-to-slack

How does it look like, please share a short status update!


(If the reply was helpful please don't forget to upvote and/or accept as answer, thank you)

Regards
Stoyan


· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Stoyan,
Thanks for the quick reply. We have:

Verified the folder structure on all the management servers

Tried to look at the Ops Mgr event logs, but we're unable to find the user account that these should be under (we were not the original installers, nor are we the SCOM admins. We just own the powershell script being executed...)

Verified the execution policy is unrestricted



While we couldn't look directly at the event logs, we were able to query SCOM's database. Looking at the Alert and Event tables we couldn't find that the alert was getting triggered. The last entry that would execute our powershell script dated back to the last date we saw the script run.

All your information was helpful to check, but it seems like our problem is further up the chain.

Thanks again!

0 Votes 0 ·