question

NndnG avatar image
0 Votes"
NndnG asked DSPatrick answered

Stuck at Enabling Feature (s) in Windows Server 2019

Hi,

After installing Windows Server 2019, it gets stuck at Enabling Feature (s) as below.
86416-hyper-v-2021-04-10-01-04-01.png

After waiting for long time, I turned off the machine. When I turned it back on, the screen is normal.

How do I restart or reset the process that was aborted?

Previously I had the same issue. When I restarted installation process from beginning using the same bootable flash drive on the same machine, it was done normally.

What I need to check so that I don’t face same issue again?

With Regards
NndnG

windows-server-2019
· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

If you resolved it using our solution, please click "Accept Answer" on a reply to help other community members find the helpful reply quickly.
If you resolve it using your own solution, please share your experience and solution here. It will be very beneficial for other community members who have similar questions.

0 Votes 0 ·
DSPatrick avatar image
0 Votes"
DSPatrick answered NndnG commented

What features? What (if any) roles or features have been installed? Has the image been patched fully? Is this a core install?




· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

I had downloaded an iso and created a bootable flash drive. Sometimes I face above issue and most of time it works fine.

Just after Windows Server installation, this screen appears automatically.

I installed Windows Server 2019 many times and every times I have seen this screen just after completion of installation.

In most cases, it gets completed successfully but sometimes it gets stuck.

In above snap, you can see, it is at 71%. It was at the same situation for long time. Then I turned off the machine.

After turning on the machine, login is successful and screen is normal.

As I aborted the ongoing process, I want to reset and restart the process but I don't know, how to do?

0 Votes 0 ·
DSPatrick avatar image
0 Votes"
DSPatrick answered DSPatrick edited

You skipped all the questions I asked. What operating system are you installing? What process are you trying to run? What are the end goals here?




5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

TeemoTang-MSFT avatar image
0 Votes"
TeemoTang-MSFT answered

Hi NndnG,

Which feature you were enabling? Have you tried enable it via PowerShell?
Try to repair system files by the following commands
Sfc /scannow
Dism /Online /Cleanup-Image /RestoreHealth

Then, enable your feature again.
Besides, you could check CBS.log for feature installation process.


If the Answer is helpful, please click "Accept Answer" and upvote it.
Information posted in the given link is hosted by a third party. Microsoft does not guarantee the accuracy and effectiveness of information.
Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

DSPatrick avatar image
0 Votes"
DSPatrick answered

Any progress or updates?




5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.