question

58024272 avatar image
0 Votes"
58024272 asked tbgangav-MSFT commented

Metric signal is missing in ADF

Hi,

9911-1.jpg
9864-2.jpgI can only see activity logs in ADF , No metric is visible for alerting . is there is any configuration issue ? I am not able to figure out what is missing


azure-data-factoryazure-monitor
1.jpg (22.5 KiB)
2.jpg (42.1 KiB)
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

1 Answer

tbgangav-MSFT avatar image
0 Votes"
tbgangav-MSFT answered tbgangav-MSFT commented

Hi @vikaschaurasia,


Thanks for reaching out!


I was able to see Metric signal in ADF v2 by going to Azure Portal -> Data factories -> <Your Data factory Name> -> Alerts -> New alert rule -> Select condition -> Select 'Metrics' in Signal type -> Metric signals are shown. For illustration, please check below two screenshots.


Screenshot1:


9931-am7.png


Screenshot2:


9827-am8.png


You can also see Metric signal in ADF v2 / ADF by going to Azure Portal -> Monitor -> Alerts -> New alert rule -> Select resource -> Select either 'Data factories' / 'Data factories (v2)' under 'Filter by resource type' section (as per your ADF version) -> Done -> Select condition -> Select 'Metrics' in Signal type -> Metric signals are shown. For illustration, please check below six screenshots.


Screenshot1:


9905-am1.png


Screenshot2:


9896-am2.png


Screenshot3:


9897-am3.png


Screenshot4:


9898-am4.png


Screenshot5:


In case of Data factories: 9906-am5.png


Screenshot6:


In case of Data factories (v2): 9888-am6.png


Let me know if this is not the case with you / if this doesn't help you.



am7.png (52.6 KiB)
am6.png (99.3 KiB)
am1.png (26.5 KiB)
am2.png (39.6 KiB)
am3.png (84.5 KiB)
am4.png (43.0 KiB)
am5.png (53.8 KiB)
am6.png (99.3 KiB)
am8.png (99.6 KiB)
· 2
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

I have 4 subscriptions . 3 subscription showing what you answered but for one subscription its not showing anywhere.

0 Votes 0 ·

@vikaschaurasia Apologize for the delayed response. In this case, I believe a deeper look at your environment and setup might be required so if you already have a support plan then I recommend you to raise a support ticket with Azure technical support. If you don't have a support plan then please send an email to AzCommunity@microsoft.com with your subscription ID and a link of this question for context and we will assist you with engaging Azure technical support.

0 Votes 0 ·