SQL server network browsing

Muhammad Ammad Shah 1 Reputation point
2021-04-11T13:44:18.957+00:00

HI,

I am installing an application that is bundled with SQL Express edition. There is an option to change the Database server, I have installed a standard 2012 edition of SQL Server on the same host.
When I try to change the database instance from desktop edition to standard edition I am unable to view the instance while browsing SQL.

I can see other instances over the network as well as on localhost desktop edition.

The named pipe is enabled on the standard edition. connections are allowed, the dfirewall is disabled (even though it's a local database).

Idea??

SQL Server
SQL Server
A family of Microsoft relational database management and analysis systems for e-commerce, line-of-business, and data warehousing solutions.
8,582 questions
{count} votes

2 answers

Sort by: Most helpful
  1. Erland Sommarskog 68,371 Reputation points Microsoft MVP
    2021-04-11T16:10:33.047+00:00

    So what happens, if you simply type .\InstanceName? Or just ., if this is a default instance? Can you connect?

    Else the reason could be that Hide instance is set to Yes for the instance. You find this setting in the SQL Server Configuration Manager. Open the node SQL Server Network Configuration, and select the Protocols for this instance, and right-click properties. See the screen-shot below.

    86595-image-2021-04-11-181152.png

    No comments

  2. CathyJi-MSFT 20,671 Reputation points Microsoft Employee
    2021-04-12T02:25:43.71+00:00

    Hi @Muhammad Ammad Shah ,

    >When I try to change the database instance from desktop edition to standard edition I am unable to view the instance while browsing SQL.

    Is this a named instance or default instance? Did you try to using SSMS to connect to the SQL server 2012 standard edition? Using SSMS 18.8, you can get it from here. In the Server name box, type the name of the instance of the Database Engine. For the default instance of SQL Server, the server name is the computer name. For a named instance of SQL Server, the server name is the <computer_name>\<instance_name>.  

    Please check the ‘Hide Instance ‘option as Erland mentioned, set the Value of this to NO.


    If the response is helpful, please click "Accept Answer" and upvote it, thank you.

    No comments