$(MAKE) in makefile gets evaluated to make instead of nmake

Saikumar 21 Reputation points
2020-06-12T06:03:42.213+00:00

I was trying to install libcurl libraries on my remote desktop following the steps mentioned in this post : How do you properly install libcurl for use in visual studio 2017?

But when I was running this command line nmake /f Makefile.vc mode=static , I was getting this error : make-3.80:*** No rule to make target '/NOLOGO'. Stop

This error was coming from this line in Makefile.vc :

@$(MAKE) /NOLOGO /F MakefileBuild.vc

After googling about the issue and going through the Visual studio documentation , I found that /NOLOGO is just an option , but somehow was being treated as a file (as can be seen from the above error).

So I tried to follow the same steps on my local machine , and I was able to install libcurl libraries. Then I tried to see what $(MAKE) evaluates to on my local machine and on my remote desktop and I found the following:

On my local machine , $MAKE is "C:\ProgramFiles(x86)\MicrosoftVisualStudio\2017\Professional\VC\Tools\MSVC\14.16.27023\bin\HostX86\x86\nmake.exe"

On my remote desktop , $MAKE is make-3.80

Can anyone suggest as to what could be the issue here ? (In both cases I am running the same command using nmake )

Not Monitored
Not Monitored
Tag not monitored by Microsoft.
37,746 questions
0 comments No comments
{count} votes

Accepted answer
  1. Anonymous
    2020-06-12T12:02:57.113+00:00

    Visual studio is not currently supported here on QnA. They're actively answering question in dedicated forums here.

    https://developercommunity.visualstudio.com/spaces/8/index.html

    https://social.msdn.microsoft.com/Forums/vstudio/en-US/home?forum=visualstudiogeneral

    --please don't forget to Accept as answer if the reply is helpful--


    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows Server] Datacenter Management

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees, and confers no rights.

    0 comments No comments

0 additional answers

Sort by: Most helpful