Cannot connect to ubuntu server from Windows 10 via ssh

asked 2021-04-13T09:32:40.083+00:00
MzHur 96 Reputation points

Hello,

I have a raspberry pie running ubuntu server 2020 and would like to connect to it via ssh directly from Windows 10. In order, for instance, to mount an ftp and view, edit directly files with vscode or atom (without going through WSL).

While I have no problem connecting to it after configuration from WSL (ubuntu) ; I cannot directly from Windows 10 Home (10.0.21301).

From WSL, everything works seamless: short ping, stable ssh connection with password authentication. From Windows, it doesn't work at all:

  • *ssh -vvv user@ip192.168.X.Y command fails (debug3: finish_connect - ERROR: async io completed with error: 10013),
  • ping 192.168.X.Y fails (General Failure), Putty as well (Network error: permission denied)
  • Test-Netconnection -Computername 'name' -port 22 fails with WARNING: TCP connect to (192.168.X.Y : 22) failed WARNING: Ping to 192.168.X.Y failed with status: 11050

ComputerName : 'name' RemoteAddress : 192.168.X.Y RemotePort : 22 InterfaceAlias : Wi-Fi SourceAddress : 192.168.X.Z PingSucceeded : False PingReplyDetails (RTT) : 0 ms TcpTestSucceeded : False

Tried so far all the following:

Ubuntu server is on same subnet 192.168.X.

Many posts can be found with similar issues regarding ssh from Windows, so it must be common; but every answer I found so far did not work in my case.

Any help is welcome if you know where the issue could be. Many thanks in advance

Windows 10 Network
Windows 10 Network
Windows 10: A Microsoft operating system that runs on personal computers and tablets.Network: A group of devices that communicate either wirelessly or via a physical connection.
1,933 questions
{count} votes

Accepted answer
  1. answered 2021-04-30T16:29:09.953+00:00
    MzHur 96 Reputation points

    To close the topic, I didn't manage to find where the issue came from.

    But I rolled back Windows from Insider preview (10.0.21301) to the current stable version (10.0.19042) with a complete clean reinstall; and the problem solved itself without even having to add Firewall rules.

    No comments

1 additional answer

Sort by: Most helpful
  1. answered 2021-04-14T05:18:54.097+00:00
    Sunny Qi 10,651 Reputation points

    Hi,

    Thanks for posting in Q&A platform.

    Based on provided information, I understand that we have the issue regarding of we cannot access ubuntu server from windows 10 client via ssh but can access ubuntu server from WSL.

    Please understand, due to environmental limitation, we do not have such ubuntu server for reproducing the issue in our lab from forum support level. I would suggest you open a case with Microsoft where more in-depth investigation can be done so that you would get a more satisfying explanation and solution to this issue.
    Also, in this way, they can have a clear picture about your issue and your environment by phone communication and live share session.

    You may find phone number for your region accordingly from the link below:

    https://support.microsoft.com/en-us/gp/customer-service-phone-numbers

    Best Regards,
    Sunny

    ----------

    If the Answer is helpful, please click "Accept Answer" and upvote it.

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.