question

RW-9574 avatar image
0 Votes"
RW-9574 asked ManuPhilip commented

Can't delete a VNet/Subnet

I have a problem where I can't delete a vnet/subnet either through the portal or az cli calls. I've had this vnet for a long time.

Early on I was deploying an app service and wanted to bind it to the subnet so it could access a storage account. I've been trying to delete it ever since.

I followed the advice/article here: https://docs.microsoft.com/en-us/answers/questions/119340/unable-to-delete-virtual-network.html

These steps didn't help. It is the only thing I have in my account right now, so I'm sure it's not bound to anything that would keep it from being deleted.

azure-virtual-network
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

1 Answer

ManuPhilip avatar image
0 Votes"
ManuPhilip answered ManuPhilip commented

Make sure that you have deleted all resources connected to the vnet/subnet is deleted before you try to delete the vnet/subnet itself. On azure portal go to Dashboard->All Resources and see if there are any hidden resources exists. You may adjust the filters as below to check it
87365-image.png



image.png (20.1 KiB)
· 2
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

That's what makes this such a problem. The vnet/subnet actually the only resource I have right now.

0 Votes 0 ·

Share the error details so that we can understand the issue in more details

0 Votes 0 ·