question

MeraBillsAdmin-8380 avatar image
0 Votes"
MeraBillsAdmin-8380 asked MayankBargali-MSFT commented

Azure Functions deployment is failing with status code 409

Hi,

For the past day or so, I am not able to deploy a new version of my Azure Functions app. When I try to deploy using Maven, I get the following error:
Status code 409, {"Code":"Conflict","Message":"There is an in progress azure migration for site 'xxx'. Please try again later."

I get the same error when I try to change the app configuration from the Azure portal.

Does anyone know what the issue may be? Any help is most appreciated!

azure-functions
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

1 Answer

MayankBargali-MSFT avatar image
0 Votes"
MayankBargali-MSFT answered MayankBargali-MSFT commented

Hi @MeraBillsAdmin-8380

Welcome to Microsoft Q&A! Thanks for posting the question.

As per the error message "There is an in progress azure migration for site 'xxx'. Please try again later" it looks like there is already a customer initiated or backend operation that is currently going on and self-resolved by itself once the upgrades are completed. The 409 conflict is expected behaviour when there is already on going operation and you tried to perform another operation while the previous operation is not completed.

If you have observed this issue for a long time then please share the CorrelationRequestId for the operation that you are performing along with the timeframe in UTC so I can check the backend logs and if the issue is due to the backend resource then I can engage my team to mitigate the issue.

· 5
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Thank you for the quick response, Mayank.

I have not initated any operatation recently, and I am getting this error for several hours now. Please find the correlation id and other details from the error event below (with PII removed).

{
"correlationId": "aa19f067-93dd-4f23-a4b5-011169d7fab9",
"eventDataId": "962401b8-8a75-4d72-9219-d7396560c4a6",
"eventTimestamp": "2021-04-14T08:57:02.4011724Z",
"level": "Error",
"operationId": "aa19f067-93dd-4f23-a4b5-011169d7fab9",
"operationName": {
"value": "Microsoft.Web/sites/config/write",
"localizedValue": "Update web sites config"
},
"resourceProviderName": {
"value": "Microsoft.Web",
},
"resourceType": {
"value": "Microsoft.Web/sites/config",
},
"status": {
"value": "Failed",
},
"subStatus": {
"value": "Conflict",
},
"submissionTimestamp": "2021-04-14T08:58:38.1767682Z",
}

0 Votes 0 ·

Thank you for the quick response, Mayank.

I have not initated any operatation recently, and I am getting this error for several hours now. Please find the correlation id and other ids below.

 "correlationId": "aa19f067-93dd-4f23-a4b5-011169d7fab9",
 "eventDataId": "962401b8-8a75-4d72-9219-d7396560c4a6",
 "eventTimestamp": "2021-04-14T08:57:02.4011724Z",
 "operationId": "aa19f067-93dd-4f23-a4b5-011169d7fab9",
0 Votes 0 ·

@MeraBillsAdmin-8380 From the backend logs looks like there were multiple operations (customer initiated) at the same time causing the issue. The same can be verified from the activity logs of your function app. Can you try to perform any operation from the portal and it is successful and retry the operation?

0 Votes 0 ·

It worked now! Thank you so much for your really quick help - it was really very helpful!

With best regards,
MeraBills Admin

0 Votes 0 ·
Show more comments