Azure P2S Connection routing table failure

Milan Kopáč 126 Reputation points

Today I started received this error message on all my devices when I was connecting to the Azure through P2S:
Custom script (to update your routing table) failed (80071392)

I didn´t change any configuration, everything was working fine and now I can´t find any solution on this problem. I tried to use an another device, I tried do repair the system, I deleted the temp files where CMROUTE.DLL is, I deleted whole VPN connection, I downloaded a new VPN setup from Azure portal, I tried to use another internet connection and still the same error.

When I checked the log I found this:
[cmdial32] 15:25:30 08 Custom Action Dll ActionType = Connect Actions Description = to update your routing table ActionPath = C:\Users\mk\AppData\Roaming\Microsoft\Network\Connections\Cm\66CA44A6-3D1B-4A14-9D68-6F8812740957\CMROUTE.DLL ReturnValue = 0x80071392
[cmdial32] 15:25:30 21 On-Error Event ErrorCode = -2147019886 ErrorSource = to update your routing table

Any advice please?

Azure Virtual Network
Azure Virtual Network
An Azure networking service that is used to provision private networks and optionally to connect to on-premises datacenters.
1,275 questions
{count} votes

Accepted answer
  1. Milan Kopáč 126 Reputation points

    Okay I found where problem is and now I´m successfully connected to the Azure VNG through a P2S connection.

    I found a problem when I was looking for some clues in the temp configuration directory (in my case the configuration directory was here: C:\Users\mk\AppData\Roaming\Microsoft\Network\Connections\Cm\66CA44A6-3D1B-4A14-9D68-6F8812740957). I opened the routes.txt file and I saw a route which was duplicated. I don´t know how is this possible or why is this happening but the route was there twice. After I deleted the one duplicated route I was able to connect to the Azure VNG through P2S.

    Now I´m trying to figure out why and how this can happen. I want to give a solution for this error for my colleagues but first I need to find where the real problem is.

    2 people found this answer helpful.

3 additional answers

Sort by: Most helpful
  1. SaiKishor-MSFT 16,656 Reputation points Microsoft Employee

    @MilanKop-1682Thank you for reaching out to Microsoft Q&A.

    To mitigate this issue, please make sure that there is no persistent route (A persistent route stays in place even when Windows starts up) in the client machine with the P2S VPN client pool. You can check this by running route print from cmd. If there's such persistent route, CMROUTE.DLL will not be able to add a route that already exists. Here is an external link which helps you with commands for removing persistent routes in Windows. Hope this helps.

    Please let us know if you have any further questions and we will be glad to assist you further. Thank you!


    Please accept an answer if correct. Original posters help the community find answers faster by identifying the correct answer. Here is how.

    Want a reminder to come back and check responses? Here is how to subscribe to a notification.

  2. Milan Kopáč 126 Reputation points

    Thank you for help but I don´t have any persistent rules when I type the route print command. I tried it on a second laptop but it´s same there. No static (persistent) route and the VPN is not working.