Azure Bastion fails to connect over RDP - Black Screen

Dave K 91 Reputation points
2020-06-15T16:40:34.29+00:00

I'm hoping somebody can help. I have tried to setup Bastion in my subscription and am hitting the following error on any VM I try to connect to. When I try to connect it opens a new browser window with black screen and to in the lower right corner I get a dialogue box saying...

'The network connection to the Bastion Host appears unstable.'

Then a dialogue box saying...

'The connection has been closed because the target machine is taking too long to respond. This is usually caused by network problems, such as a spotty wireless signal, or slow network speeds. Please check your network connection and try again or contact your system administrator.'

Bastion appears to be setup correctly, has its own dedicated /27 subnet within the same vnet as the VM's I'm trying to connect to. There is no NSG applied on either the VM or on the Bastion subnet. Presumably if no NSG is applied there should be nothing internally within Azure blocking it. Yet I cannot seem to establish a connection to any of my VM's.

Worth a mention I tried looking this up before posting and seen some people mentioning they had set their RDP port to something other than 3389, and resetting this back fixed the issue. I have not changed the RDP port on any VM and confirmed all are still set to 3389.

Any help would be appreciated.

Azure Virtual Machines
Azure Virtual Machines
An Azure service that is used to provision Windows and Linux virtual machines.
7,518 questions
Azure Bastion
Azure Bastion
An Azure service that provides private and fully managed Remote Desktop Protocol (RDP) and Secure Shell (SSH) access to virtual machines.
247 questions
{count} vote

8 answers

Sort by: Most helpful
  1. Bolaji Binuyo 21 Reputation points
    2021-02-06T16:42:36.627+00:00

    Just in case anyone is still having this issue. Also make certain your VM is running while attempting to initiate a remote connection. I was getting similar error until I realized intended VM was set to stop. Starting up the VM and initiating a Bastion connection fixed my error.

    4 people found this answer helpful.
    0 comments No comments

  2. Dave K 91 Reputation points
    2020-06-17T07:51:58.97+00:00

    I got it sorted. In case this is helpful to anyone else. We have a firewall deployed in Azure and had added a UDR for 0.0.0.0/0 with next hop going to the FW. This was on the route table associated with our VM subnet, not the Bastion subnet. Basically this meant unless another route was explicitly defined then all traffic from our VM's would route through the FW. I added another UDR for the Bastion subnet and this resolved the issue.

    3 people found this answer helpful.

  3. Dev Sharma 11 Reputation points
    2022-01-10T01:30:11.23+00:00

    I fixed it by clicking on the VM=>Run command=>SetRDPPort then "Run Command Script" window comes where you give the RDP Port number and Hit run. after the commend is run successfully, go back to the VM and connect via Bastian.....it works

    2 people found this answer helpful.

  4. Saurav Das 6 Reputation points
    2021-04-18T09:43:04.26+00:00

    what I noticed today that when I create initial connection via the bastion, the first time connection is seamless.
    Its the subsequent access is where it is going all wrong and getting network connectivity issue

    Anyone else faced and solved such an issue ? it will be helpful

    1 person found this answer helpful.
    0 comments No comments

  5. Ronen Ariely 15,101 Reputation points
    2020-06-15T19:09:26.99+00:00

    Hi,

    The issue regarding changing the port of the RDP is known. Can you confirm that you can connect to the machine using RDP with the default port 3389. If you do not succeed then maybe this configuration was changed and we will need to fix it first

    Basically all the information can be found in the following thread:

    https://github.com/MicrosoftDocs/azure-docs/issues/33632