Task Scheduler misses all tasks scheduled to run at night

Thore Lenhartzen 96 Reputation points
2021-04-19T08:46:28.1+00:00

I have added a task that shall run at 3 o'clock in the morning every night. It has been working fine for years but some weeks ago, I discovered that it was no longer running.
After checking around a bit I also discovered that no other tasks scheduled at night (when computer is sleeping) was running. They all are started as soon as I unlock the computer. Then I get a "Misses task started" warning.

Tasks that are started when I am logged in seems to be running according to schedule.

Here is an example:
88940-image.png

The task should be running as SYSTEM user with highest priveleges whether I am logged on or not.
89054-image.png

All tasks trigged on times when the computer is asleep behaves the same way. I have not changed any of the auto-generated tasks but I have played around with several test-tasks checking things like "Enabled", "Wake the computer....". Nothing helps.

Any help on this matter would be highly appreciated!

Windows 10
Windows 10
A Microsoft operating system that runs on personal computers and tablets.
6,043 questions
Windows Server
Windows Server
A family of Microsoft server operating systems that support enterprise-level management, data storage, applications, and communications.
8,270 questions
No comments
{count} votes

Accepted answer
  1. Thore Lenhartzen 96 Reputation points
    2021-04-28T07:13:26.967+00:00

    YESS ! That did it. Thank you Dgorter!
    I will not speculate on why or how it worked, byt this was helpful at last:

    powercfg /setacvalueindex 381b4222-f694-41f0-9685-ff5bb260df2e 238c9fa8-0aad-41ed-83f4-97be242c8f20 bd3b718a-0680-4d9d-8ab2-e1d2b4ac806d 1

    best regards Thore

    No comments

4 additional answers

Sort by: Most helpful
  1. Carl Fan 6,681 Reputation points Microsoft Employee
    2021-04-20T08:58:05.347+00:00

    Hi,
    According to your description, would you please check the task schedule history, is there any event log regarding this issue?

    Also did you got the "Run task as soon as possible after a scheduled start is missed" checkbox checked?
    Meanwhile I suggest that you could check for update firstly.
    If any security updates found be found, installing to check.
    Hope this helps and please help to accept as Answer if the response is useful.
    Best Regards,
    Carl


  2. Carl Fan 6,681 Reputation points Microsoft Employee
    2021-04-22T09:59:01.52+00:00

    Hi@ ThoreLenhartzen-2651,
    Thank you for your information.
    Please type "winver" in Search Bar to check the OS build.
    Perform a clean boot and disable security software temporarily.
    https://support.microsoft.com/en-us/topic/how-to-perform-a-clean-boot-in-windows-da2f9573-6eec-00ad-2f8a-a97a1807f3dd
    As you said, "Wake the computer to run this task" and other options had been checked. But all tasks set up to run at specific times are missed unless you logged in.
    I also can't confirm if the parameters on the properties have something wrong. It has been working fine for years but some weeks ago it didn't work. If delete one task and recreate, if it works fine.
    Hope this helps and please help to accept as Answer if the response is useful.
    Best Regards,
    Carl


  3. Darrell Gorter 346 Reputation points
    2021-04-23T17:33:19.093+00:00

    Hello,
    Open an elevated cmd prompt:
    Run powercfg /query
    Look for the section on Allow Wake timers
    Similar to >Power Setting GUID: bd3b718a-0680-4d9d-8ab2-e1d2b4ac806d (Allow wake timers)
    Check the current AC and DC power setting Index values
    What are the values on them?

    Also open gpedit.msc ( Start - run gpedit)
    Check this policy
    Computer configuration - administrative Templates - Windows Components - Maintenance Scheduler
    What is the value of Automatic Maintenance Wakeup Policy


  4. Artemiy Moroz 266 Reputation points
    2021-04-24T16:29:28.62+00:00

    hi there! I would suggest you open BIOS settings and check if your BIOS allows Wake on RTC signal.