Visual studio crashes when create/load new project

Benya 1 Reputation point


For some reason when i try to create a project with Visual studio 2019 (Enterprise edition) it just crashes, managed to create the sln files but then whenever it tries to open it with visual studio it crashes down.

I've tried with .NET core 2.1 and 3.1 but none works.

How can i fix this issue?

Thanks in advance

edit: It doesn't create the SLN files even at some tries.

Visual Studio
Visual Studio
A family of Microsoft suites of integrated development tools for building applications for Windows, the web and mobile devices.
2,815 questions
{count} votes

4 answers

Sort by: Oldest
  1. Yogi 336 Reputation points

    I would suggest you to reinstall it and see it it solves your problem.

  2. Michael Taylor 41,431 Reputation points

    Run VS in safe mode. If it works in safe mode then you have an extension getting in the way.

    Could also be a permissions issue. Try saving the solution to a local, simple path that you have write permissions to such as C:\Temp or something.

    Temporarily disable AV and see if AV is blocking the request.

  3. Benya 1 Reputation point

    Still need help with this;
    Tried to re-install several times with different setups / hard drives but to no avail.

    I re-installed and tried again with a other hard drive on the same system but does not work;
    checked the Windows even viewer and it says the following:

    Fault bucket 1883833166513175316, type 1
    Event Name: APPCRASH
    Response: Not available
    Cab Id: 0

    Problem signature:
    P1: devenv.exe
    P2: 16.9.31205.134
    P3: 606b75b3
    P4: clr.dll
    P5: 4.8.4341.0
    P6: 6023024f
    P7: c0000005
    P8: 000b0daf

    Attached files:

    These files may be available here:

    Analysis symbol:
    Rechecking for solution: 0
    Report Id: 25ce04c5-4a69-4230-a217-bb7c8acc21f1
    Report Status: 268435456
    Hashed bucket: cf1ac24f70c9d208ba24b848b21dfb14
    Cab Guid: 0

    <Event xmlns="">

    • <System>
      <Provider Name="Windows Error Reporting" />
      <EventID Qualifiers="0">1001</EventID>
      <TimeCreated SystemTime="2021-04-21T19:28:03.014060000Z" />
      <Security />
    • <EventData>
      <Data>Not available</Data>
      <Data />
      <Data />
      <Data>\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER46E8.tmp.dmp \?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER4DA0.tmp.WERInternalMetadata.xml \?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER4DC0.tmp.xml \?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER4DBE.tmp.csv \?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER4DCE.tmp.txt</Data>
      <Data />


    • System
      • Provider
      [ Name] Windows Error Reporting
      • EventID 1001
      [ Qualifiers] 0 Level 4 Task 0 Keywords 0x80000000000000
      • TimeCreated
      [ SystemTime] 2021-04-21T19:28:18.693749900Z EventRecordID 13230 Channel Application Computer DESKTOP-8AESF4D5 Security
    • EventData 125730739576
      Not available
      0 \?\C:\Users\benya\AppData\Local\Temp\VSTelem.Out\202104211928_D16.9_16.9.31205.134_5968_1fe39d05-8361-4cf1-8db1-2e8d388dfc4d.tcdb \?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER9D36.tmp.WERInternalMetadata.xml \?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER9D56.tmp.xml \?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER9D57.tmp.csv \?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER9D77.tmp.txt
      \?\C:\ProgramData\Microsoft\Windows\WER\ReportArchive\NonCritical_PerfWatsonTcdb_688f135dd185f2a8133a474a2518efc6ce6cc4a_00000000_3a6f170c-3ea5-436e-a43e-5f0bf164c103 0

    Could this have to do with a concern i had before regarding during startup it says "checking disk chkdsk if you dont want to you can press any button on the keyboard" or something alike.
    I've had some BSOD also before but nothing serious (i thought)

    Please let me know if you can help.

  4. AnnaXiu-MSFT 13,031 Reputation points

    Hi @Benya ,

    Welcome to Microsoft Q&A!

    Have you installed other versions of VS on your computer? And check if the same situation appears or not.

    According your information, it seems be caused by your Operating System, please try to update your Windows to the latest version and refer to the following guide to fix your Windows errors:
    Then, run your VS as administrator to try again.


    • If the answer is helpful, please click "Accept Answer" and upvote it.
      Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.