Trying to run a previously compiled Visual Studio / CMAKE project that was working before and now getting errors

Ethan Bowes 1 Reputation point
2021-04-22T06:21:08.577+00:00

Hey there. It took me a few weeks to compile from a github a project that was made in 2015 and CMAKE. I believe I was using Visual Studio 2019 to do it. However, I reformatted my computer recently, and now when I run the executables, I get a few errors.

The errors are:
'The code execution cannot proceed because ucrtbased.dll was not found. Reinstalling the program may fix the problem.'
'The code execution cannot proceed because VCRUNTIME140D.dll was not found. Reinstalling the program may fix the problem'.

When I ask on the discord server for the project why this is, they say that I just have to install the build tools the developer has provided. I assumed that I would have to reinstall all of Visual Studio 2019, but I'm not sure the components I would need, and am limited with bandwidth at my current rental. I've tried installing the Build Tools exe and it doesn't change the error messages.

The folder comes with a ucrtbase.dll, and when I try to rename it and I get an error saying, 'it is not designed to run on windows or contains an error'. I'm assuming I need the ucrtbased.dll not base..

Any idea how to fix this?

C++
C++
A high-level, general-purpose programming language, created as an extension of the C programming language, that has object-oriented, generic, and functional features in addition to facilities for low-level memory manipulation.
2,640 questions
No comments
{count} votes

1 answer

Sort by: Most helpful
  1. David Lowndes 4,231 Reputation points MVP
    2021-04-22T08:08:45.897+00:00

    You've built a debug version (the DLL names you show are the DEBUG ones), and the debug DLLs are not redistributable; they're only available with Visual Studio (and specifically the C++ tools in it).
    As you suspect, you'll need to re-install Visual Studio with the native C++ components (Desktop development with C++).

    No comments