MEM Configmgr 2002

Sharmindh Lakshmanan 1 Reputation point
2021-04-22T10:40:25.273+00:00

error: Setup cannot create the database on the SQL Server

Tried multiple reinstallations of both SQL 2017 and CM, getting the same error.

Any advise on this90342-1619087455371.jpg

Microsoft Configuration Manager
SQL Server
SQL Server
A family of Microsoft relational database management and analysis systems for e-commerce, line-of-business, and data warehousing solutions.
8,561 questions
{count} votes

5 answers

Sort by: Most helpful
  1. Sharmindh Lakshmanan 6 Reputation points
    2021-05-03T07:10:23.923+00:00

    @Colin Ford @HanyunZhu-MSFT

    Thank you for your support and suggestions.

    The problem has been resolved after several attempts.

    Due to a corrupted iso file, a new copy of MECM2103 was downloaded.

    It functions flawlessly.

    Thanks


  2. HanyunZhu-MSFT 1,826 Reputation points
    2021-04-23T08:41:34.847+00:00

    @Sharmindh Lakshmanan

    Thanks for posting in Microsoft Q&A forum.

    Could you please share your ConfigMgrSetup.log with the sensitive information masked, in which may provide specific reasons for the error.

    Accroding to the existing information, this problem may caused by that the current login machine account does not have sufficient permissions.

    It is recommended to check the permissions of the machine account from two places first:

    1. Microsoft SQL Server Management Studio
      Check whether the account is the System administrator, through the path: Security > Server Roles > sysadmin.
      90731-1.png
      Confirm that the account has permission to Create any database in the propertities of the SQL Server.
      90732-21.png 90733-22.png
    2. Local Users and Groups
      Check if the current account is an administrator of the local machine.
      90734-3.png

    Hope the above information is helpful to you.


    If the response is helpful, please click "Accept Answer"and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    No comments

  3. Sharmindh Lakshmanan 1 Reputation point
    2021-04-27T08:57:57.933+00:00

    @HanyunZhu-MSFT

    Thank you so much for your quick and detailed reply.

    Checked all the setting you mentioned, tried reinstalling CM again after confirming the settings.

    I am still facing the same error code. 90992-log.jpg

    No comments

  4. HanyunZhu-MSFT 1,826 Reputation points
    2021-04-28T08:26:19.957+00:00

    @Sharmindh Lakshmanan

    Thanks for your updated information.

    First you can check whether there is any database that remains due to previous installation in SQL Server Management Studio.

    1. Connect to an instance of SQL Server Database Engine in object explorer.
    2. Expand Databases.
    3. If there is any remaining database, right-click it and choose Delete.
      Then you can try to install ConfigMgr again.

    If the installation still fails, it is suggested to delete the SQL instance and install new.
    To uninstall the instance of SQL Server, you can refer to this article: https://learn.microsoft.com/en-us/sql/sql-server/install/uninstall-an-existing-instance-of-sql-server-setup?view=sql-server-ver15&tabs=Windows10 to confirm that the instance is completely deleted.

    If the above two methods fail, it is better to upload the latest complete ConfigMgrSetup.log (with the sensitive information masked).


    If the response is helpful, please click "Accept Answer"and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    No comments

  5. Colin Ford 1,026 Reputation points
    2021-04-28T12:20:59.663+00:00

    Connect to the SQL instance using SQL Server Management Studio and check if there is a database called CM_***. If so, this was left over from the previous install. Remove it from SQL manually (provided you don't need it) and retry the MEMCM installation.

    No comments