How can I get the browse dialog to see my network share

Amy Friend 21 Reputation points
2021-04-22T20:12:44.34+00:00

Using Windows 10 v2004 build 19041.928 I have mapped a synology DS220+ NAS which has no problem being seen and accessed in File Explorer. I was able to point "My Documents" to this drive, though it shows up as the drive letter instead of as "My Documents". However, in any application, when I select browse to pick a folder on that drive, I get an error that the drive is unavailable. I can get to it through windows explorer just fine before, during and after this error but the error will not go away. Even if I copy/paste the full path into the folder selection path, I will still get an error saying that the resource is unavailable and cannot proceed. How do I get the application browse selector to recognize that the mapped NAS is available?

Windows 10 Network
Windows 10 Network
Windows 10: A Microsoft operating system that runs on personal computers and tablets.Network: A group of devices that communicate either wirelessly or via a physical connection.
1,943 questions
{count} votes

Accepted answer
  1. Candy Luo 12,456 Reputation points
    2021-04-23T03:35:51.393+00:00

    Hi,

    Based on my understanding, you mapped NAS in windows 10 and have no problem to access mapped NAS in File Explorer. But you cannot browse the mapped driver via any application. Is that right? Please feel free to let me know if I have any misunderstanding.

    It seems the issue is that you are running some programs with administrative privileges but they cant see drives mapped as a standard user.

    Try to configure the EnableLinkedConnections registry value to 1 and then see if works:

    1.In Registry Editor, locate and then click the following registry subkey:HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System

    2.Right-click Configuration, select New, and then select DWORD (32-bit) Value.

    3.Name the new registry entry as EnableLinkedConnections.

    4.Double-click the EnableLinkedConnections registry entry.

    5.In the Edit DWORD Value dialog box, type 1 in the Value data field, and then select OK.

    6.Exit Registry Editor, and then restart the computer.

    For more details, you can refer to the following article:

    Mapped drives are not available from an elevated prompt when UAC is configured to Prompt for credentials

    Best Regards,
    Candy


    If the Answer is helpful, please click "Accept Answer" and upvote it.

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    No comments

0 additional answers

Sort by: Most helpful