Windows Update prevent automatic reboot

asked 2021-04-27T14:45:06.14+00:00
CS10NET 66 Reputation points

Hi, looking for some solution on preventing a server from rebooting after windows updates are installed... ever. I know there is a policy "No auto-restart with logged on users for scheduled automatic updates installations" but if I am reading that correctly, that means if there is a logged on session, Don't Reboot. Yes, that sounds great but I'm not always going to have a logged on session. Seems that with Windows Server 2016 or 2019, servers are getting rebooted "outside business hours". Here is how I have the GPO configured:

  • Configure Automatic Updates - 3 - Auto download and notify for install
  • Automatic Updates detection frequency - 1 hour
  • Display options for update notifications - 1 - Disable all notifications, excluding restart warnings

Now we have those settings in place and we use Azure Update Management to install the updates and have that explicitly set to not reboot. However, I believe Azure is doing its job and not rebooting because I see the job ending successfully. The server still reboots off business hours and i believe this is coming from the Windows server itself.

Any help is appreciated.

Azure Virtual Machines
Azure Virtual Machines
An Azure service that is used to provision Windows and Linux virtual machines.
4,557 questions
Azure Automation
Azure Automation
An Azure service that is used to automate, configure, and install updates across hybrid environments.
684 questions
No comments
{count} votes

1 answer

Sort by: Most helpful
  1. answered 2021-05-01T23:00:42.73+00:00
    olufemia-MSFT 2,781 Reputation points

    Hello anonymous user - thanks for the post. Check out this regedit solution. Not an official recommendation but hope it helps. :)

    No comments