question

LauraAmaro-4518 avatar image
0 Votes"
LauraAmaro-4518 asked

HoloLens 2 - Unity: When I add URP or HDRP to a project, the app doesn't launch.

Hi, community!

I'm working on an app for the Hololens 2 on Unity. I would like to add Visual Effects with the VFX Graph, so I need to use the Universal Render Pipeline (URP) - or the HDRP. Just as a test I created a new project with the 3D template and followed this tutorial for the setup: https://docs.microsoft.com/en-us/windows/mixed-reality/develop/unity/tutorials/mr-learning-base-02?tabs=openxr . Instead of using the samples I placed just a cube in the scene, built and deployed it on Visual Studio. It worked as expected on the HoloLens. For some reason, I had to set the visibility of the spatial awareness to none to see the cube and make it work (default MRTK config files for OpenXR).

Then I added the URP, the URP-Asset and updated the material of the cube. To improve the performance I set the quality level to very low and unchecked the setting Optimize Mesh Data. I built and deployed it on VS again. Well, it doesn't start. After 10 min loading, I decided to stop waiting and tried the same process with the HDRP, but I had no success.

I'm using:

Visual Studio Community 2019 16.9.4

Unity 2020.3.1f1 (LTS)

MRTK v1.0.2103.3 beta (MRT-Fundation 2.7.0. preview 3)

MR OpenXR Plugin 0.9.2 preview

I would really appreciate some help! I do not understand why the HoloLens can't load the project. It is just a cube! Am I missing something? Doesn't the URP work with HoloLens?

Thank you very much in advance.

Laura

hololens-development
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

0 Answers