SSRS report - image is not showing in the report preview

Zolotoy 171 Reputation points
2021-05-03T12:03:36.403+00:00

I have a simple SSRS report with an embedded image. When I preview it I see the red cross. Exactly the same report in the Power BI paginated report shows image correctly. What seems to be a problem?

Thanks

SQL Server Reporting Services
SQL Server Reporting Services
A SQL Server technology that supports the creation, management, and delivery of both traditional, paper-oriented reports and interactive, web-based reports.
2,124 questions
No comments
{count} votes

2 answers

Sort by: Most helpful
  1. Joyzhao-MSFT 15,361 Reputation points Microsoft Employee
    2021-05-04T01:46:37.877+00:00

    Hi @Zolotoy ,

    1. Please check if the steps to embed iamge are correct: Embed an Image in a Report (Report Builder and SSRS).
    2. I want to know the version of SSRS you are using, and the format of the embedded image you are using.
      Related information reference:
      FIX: An embedded image of a report is incorrectly displayed as a red cross in SQL Server 2008 Reporting Services and in SQL Server 2008 R2 Reporting Services
    3. Try to deploy the report to Report Manager and check whether the image is displayed correctly.
    4. Replace the image with an image in the same format in VS or Report Builder to check whether the image is displayed correctly.
    5. Please describe the environment in which the error occurred as much as possible. Check if there is any error message.

    Best Regards,
    Joy


    If the answer is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    No comments

  2. mark goldin 661 Reputation points
    2021-05-04T08:43:18.33+00:00

    Strangely it started working.